cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Show a percentage from Sharepoint list

Hi, I have a calculated column (CompletionScore) in a sharepoint list that is formated as a number, to zero decimal places, and as a percentage.

 

I want to show it in Powerapp. I have tried:

Text=ThisItem.CompletionScore

 

but i just get 1.0000000000000 or 0.8666666666666

 

I have also tried:

Text=text(ThisItem.CompletionScore,"0%")

and have played around with the calculated column, changing it to a text formart, and also using Round, but i'm going in circles. I have control over the Sharepoint list and the calculatoin, so can change it if necessary.

 

Any help?

Thanks.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

I revisted this problem this morning, and have found a solution:

 

Concatenate(Text(Round(Value(ThisItem.CompletionScore)*100,0),"[$-en-US]0"),"%")

 

It seems rather clunky, but it works. 

 

Thought I'd post in case someone else gets stuck like me.

View solution in original post

9 REPLIES 9
Anonymous
Not applicable

I revisted this problem this morning, and have found a solution:

 

Concatenate(Text(Round(Value(ThisItem.CompletionScore)*100,0),"[$-en-US]0"),"%")

 

It seems rather clunky, but it works. 

 

Thought I'd post in case someone else gets stuck like me.

View solution in original post

Where did you put that formula - it doesn't seem to work in my "Format" field?

Anonymous
Not applicable

I didn´t understand where to insert the code. I have the same problem (see pic). I uploaded data from an excel table, and one of my columns have a percentage.

 

In the excel document the column is formated as percentage. But when i upload to the Powerapp, that specific column shows only decimals.Full tableFull tableLeft (powerapp) is the value in decimal, uploaded from the right (excel) in percentage.Left (powerapp) is the value in decimal, uploaded from the right (excel) in percentage.

kaleyanne
Advocate I
Advocate I

In the Text field of the DataCardValue set it equal to:

Text(Value(Parent.Default*100),"[$-en-US]0%")

 

That worked for me. I hope it works for you too! 

Does anyone know why this happens? 

 

I have a slightly different scenario whereby I have a number field in SharePoint which has a minimum & maximum value (0-100 respectively); this is then being displayed as a percentage with no decimal places. When a user attemps to submit a value (i.e. 20) through PowerApps, the form submission fails because it expects a value between 0-1?

 

Does anyone know why this is, and how to workaround this particularly strange issue? Does using the "display as percentage" option in SharePoint mean that the value has to be a decimal value between 0 and 1? 

Were you able to find a solution for this issue? I have the same problem.

Found answer at StackExchange

 

Update below properties for the DataCard (assuming name of field is "Numbers"):

  1. 'Default' field to 'ThisItem.Numbers*100'
  2. 'Update' field to 'Value(DataCardValue3.Text/100)' --- DataCardValue3 in my case

THX its working!

Is there a way to get this to show the first 2 decimals?

 

Text(Value(Parent.Default*100),"[$-en-US]0%")

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (15,419)