cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mischa_van_o
Advocate II
Advocate II

Since this morning any backend connection from any of our powerapps is extermely slow or even times out (Sharepoint and SQL)

Since this morning all of our Powerapps are extremely slow or time out. We noticed this is happening to any powerapp regardless of the type of backend, so happens with SharePoint connections, SQL connections and 365 connections. Looks like Powerapps has an issue to connect to any of the connections. Location is Europe, location of Azure resources is Germany West Central. 

45 REPLIES 45
dzo_marija
Frequent Visitor

Same in Lithuania (Europe), please fix it ASP.

ShpxLbh
Frequent Visitor

I made submit for that and send info on twitter, but they 'don't know any issues'..  one day without all power apps solutions. eh..

AbderIchou
Frequent Visitor

Same story here, all connections to our Azure backend services seem to be invalid. Any connectors using these connections are extremely slow. This has big impact within our team! 

KubaL
Advocate I
Advocate I

I've got some confirmation from Microsoft - "that an ongoing performance issue related to PowerApps, several connectors is reported globally and the engineering team is working on it"

DeniNinkovic
New Member

I have the same issues. Any backend call is extremely slow. Timeout all the time. Netherlands server. It can take up to 5 minutes for a simple request.

WaynePeinke
Advocate I
Advocate I

Title: Users may encounter performance issues or latency with Microsoft Power Apps connectors
MM480454, Last updated: December 5, 2022 4:01 PM
Estimated start time: December 5, 2022 2:40 PM
Status: Service degradation
User impact: Users may encounter performance issues or latency with Microsoft Power Apps connectors.
Current status: We're reviewing service monitoring telemetry to isolate the root cause and develop a remediation plan.
Scope of impact: Impact is specific to any who is hosted in North Europe.

Are you seeing this under service health @WaynePeinke ? We're seeing this issue across multiple tenants here in the EU, but no issues under service health in the Microsoft 365 admin center

Same for us - in the "Service status" section in the Office 365 Admin Center, the status for the services "PowerApps" and "Power Automate" is still green with a checkmark...

Tjan
Resolver I
Resolver I

According to the service health section in the admin center, the problem should be fixed?

I hope it's indeed fixed for everyone!! Checking my own flows right now.

 

EDIT: the incident dissappeared from the service health section.

 

EDIT2: my flows work again! SQL Connection works properly again. Finally! Hope it's solved for everyone here.

ShpxLbh
Frequent Visitor

it works. thanks for update. 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (2,873)