cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver II
Resolver II

Slow screen navigation suddenly

Sometime in the past 7-10 days my apps started performing sluggish on screen transitions without any changes on my part. Has anyone else experienced this? (It doesn't perform this poorly in Designer)

 

App Layout:

Screen 1 - Gallery of "Models", touching a model has a simple Navigate(Screen2,UnCover)

Sreen 2 - Gallery of "Parts", filtered per Model chosen from Screen1. Each tile has a label for "ThisItem.PartNumber", "ThisItem.Description", and an image of the part

 

Notes, what I've tried/eliminated without success:

  • There are no Rules in the app
  • All gallery Items use collections created at startup (not directly linked to source), but I still tried turning off "Delayed Load"
  • Changed the Navigate transition to None
  • Image of part on Screen2 gallery uses LookUp to display the right image, so I removed the image to check
  • Removed the Filter from Screen2 gallery Items
  • I now have a gallery on Screen2 showing just PartNumber and Description plain text for all items in a local Collection (674 part numbers total)

 

Not sure where to go next, seems like I've gotten it down to the most basic transition and gallery display I can with still no difference in transition time. It previously was very snappy, now it can take anywhere from 3sec to a minute to change to a screen of pre-loaded data in a collection. Operators indicated to me it even freezes at times and they just turn the tablet off (taken with a grain of salt)

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Resolver II
Resolver II

Re: Slow screen navigation suddenly

I'm actually using the PowerApps app within Windows 10 on the tablet (Lenovo MIIX).  The data hasn't grown, and I tried everything to minimize controls with no luck.  Thing is, nothing changed unless updates have occurred in that timeframe...we did have Windows updates pushed down recently. IT has been hitting things with group policy hammers as well.

 

I did attempt it in Chrome with better results. I quit using it before because of issues but seems more solid this time around. If no one else is seeing this issue I may just switch to Chrome and move along.

View solution in original post

2 REPLIES 2
Highlighted
Resolver III
Resolver III

Re: Slow screen navigation suddenly

Hi strategery,

 

Are you using datasources to populate your collections? Is the data growing? Have you tried a different browser? I have noticed Edge does not respond as well as Chrome with P-Apps and Pbi.

 

I experienced the same thing and it was related to two things:

 

1) Data I populated my Collections with was growing and cause the app to run slower.

2) I had too many controls within my gallery which I minmized.

Highlighted
Resolver II
Resolver II

Re: Slow screen navigation suddenly

I'm actually using the PowerApps app within Windows 10 on the tablet (Lenovo MIIX).  The data hasn't grown, and I tried everything to minimize controls with no luck.  Thing is, nothing changed unless updates have occurred in that timeframe...we did have Windows updates pushed down recently. IT has been hitting things with group policy hammers as well.

 

I did attempt it in Chrome with better results. I quit using it before because of issues but seems more solid this time around. If no one else is seeing this issue I may just switch to Chrome and move along.

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (5,639)