cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver I
Resolver I

Some form fields break after I added new feilds in sharepoint

not sure what happened but I added a few new columns to a SharePoint list and the form related to it broke. on lt some of the fields broke not all of them. Its giving me a runtime error of "data source invalid for function". where the data source hasn't changed I just added to the columns on sharepoint and haven't changed anything else.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Resolver I
Resolver I

Re: Some form fields break after I added new feilds in sharepoint

So, I asked this question and rephrased it a bit to better encapsulate what I meant here:

https://powerusers.microsoft.com/t5/Building-Power-Apps/form-breaks-when-adding-new-column-to-sharep...

 

apparently it is a known issue and the  only way I found to fix it is cut and pasting the form and it reloads the form.

View solution in original post

4 REPLIES 4
Highlighted
Microsoft
Microsoft

Re: Some form fields break after I added new feilds in sharepoint

Hi miguelrodrigue

 

Could you share with us some screenshots?

 

Thanks.

JAvier.

 

 

Highlighted
Resolver I
Resolver I

Re: Some form fields break after I added new feilds in sharepoint

Screenshot (8).png

I didn't change anything about the audit form type and its saying the data source is invalid.

it does the same thing for a couple other parts as well

Highlighted
Microsoft
Microsoft

Re: Some form fields break after I added new feilds in sharepoint

Hi miguelrodrigue

 

Sorry for the delay, could you show me the error that you have?

Did you check the Source data in the properties?

 

screen1.jpg

 

Regards,

Javier

Highlighted
Resolver I
Resolver I

Re: Some form fields break after I added new feilds in sharepoint

So, I asked this question and rephrased it a bit to better encapsulate what I meant here:

https://powerusers.microsoft.com/t5/Building-Power-Apps/form-breaks-when-adding-new-column-to-sharep...

 

apparently it is a known issue and the  only way I found to fix it is cut and pasting the form and it reloads the form.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (9,890)