cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Specified folder not found

I have a Sharepoint list form created with Powerapps, within the form I created a button that triggers a flow. The flow sends an email from a shared mailbox. But I'm experiencing the following error: Action 'Send an email from a shared mailbox' failed. Specified folder not found. clientRequestId: f3dd14ea-c871-4342-a910-fccd433a48ef serviceRequestId: 862cd9e6-be3c-43a1-9529-b21df7f02d04

test failed.PNG

Please Advice, thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @Anonymous,

 

If here you are using the Shared-Mailbox to send the email, then please make sure the current login account have the proper permission to access the Shared Mailbox:

Qouted:

"

This operation sends an email from a shared mailbox. Your account should have permission to access the mailbox for this operation to succeed.

"

Connector reference.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
Community Support
Community Support

Hi @Anonymous,

 

If here you are using the Shared-Mailbox to send the email, then please make sure the current login account have the proper permission to access the Shared Mailbox:

Qouted:

"

This operation sends an email from a shared mailbox. Your account should have permission to access the mailbox for this operation to succeed.

"

Connector reference.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-micsh-msft 

In my own case; I have a button trigger from PowerApps.

I have permissions to do send from the Shared Mailbox.

However, what I have noticed is this:

* When I click the button from PowerApps using my own account, the flow runs successfully.

* When another user does the exact same action, the flow fails with a 404 (Specified folder not found) error.

 

Should you need the ClientID and RequestID for further investigation, please do let me know.

 

Thanks.

 

Emmanuel

@v-micsh-msft, I have the sam problem as @eopara above - the "send mail from shared mailbox" works for the creator of the powerapp/flow, but not for other users. This has worked since october last year, but suddenly stops working.

The other users claim to have full access to the shared mailfolder. Any other reasons (and solutions 🙂 ) why it would fail for them and not for the creator of the powerapps/flows account? 
FYI the account creating the powerapp and the flow is not the one "owning"/creating the shared mail folder, and it still works for this account. 

 

Thanks in advance!

BR.
Tone Farsund

Also dealing with the same issue, was working now its not. Users activating the flow have appropriate permissions to the folder.

In my case the permissions were not changed, but the shared folder was "hidden" and thus it did not work. As soon as it was changed to "visible" it worked again 🙂 

What do you mean by hidden? Im having this same issue. Thanks! 

any solution for this issue?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,868)