cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pimverver_fugro
Regular Visitor

Still error on lookup field

Hello all,

 

As it appears in this blog from june 2016 (https://powerapps.microsoft.com/en-us/blog/support-for-lookups/) lookup fields are supported in Powerapps from version 2.0.440 onwards.

 

I have Powerapps 2.0.783 (webversion), however when defining a connection wih a list which contains a lookup datatype field, it produces the known error 'The required field xxxxx dataype that is not supported.'

 

Any solutions?

 

Kind regards,

 

Pim Verver

8 REPLIES 8
Jeff_Thorpe
Super User
Super User

SharePoint Lookup fields are supported in PowerApps and the ones I am using are working. It is hard to tell what is going on because we can't see how everything is configured, so I have a few questions:

 

  • Is this happening when creating a new app using this list
  • What type of column are you looking up to
  • Are you showing additional fields and if so, what type of fields are they
  • Does the lookup allow multiple values
  • Does the lookup field work correctly in the OOB SharePoint list form

 

 



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Dear Jeff,

 

This is indeed happening when I create a Powerapp from the link in Sharepoint online (Office365), or from within the Powerapps Studio when creating an app

The lookingup column is of type onelineoftext (max 255), it must contain values and contain unique values

I am showing 5 additional fields, 4 of type onelineoftextof type, 1 of type calculated

The lookup column doesn't allow multiple values.

And the lookup field works correctly in the OBB Sharepoint List Form.

 

Kind regards,

 

Pim

I have tried to recreate the issue based on your feedback but I am not getting any errors. Can you provide a screenshot of where the error is happening?



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Hi Jeff,

 

Thank you for looking into it.

 

The complete error text is: {

  "status": 400,

  "message": "The required field \"SAP-nummer\" data type is not supported\r\nclientRequestId: d6b23aae-47f0-45e9-847a-4172f2b0f11b\r\nserviceRequestId: 7ff34b9e-1005-5000-eae6-c507edb5c501",

  "source": "https://fugro.sharepoint.com/sites/DeformatiemetingenHBR/_api/SP.APIHubConnector.GetTableMetadata(li...",

  "errors": [

    "-1",

    "Microsoft.SharePoint.SPConnectorException"

  ]

}

Stack: Core.ApplicationError: {

  "status": 400,

  "message": "The required field \"SAP-nummer\" data type is not supported\r\nclientRequestId: d6b23aae-47f0-45e9-847a-4172f2b0f11b\r\nserviceRequestId: 7ff34b9e-1005-5000-eae6-c507edb5c501",

  "source": "https://fugro.sharepoint.com/sites/DeformatiemetingenHBR/_api/SP.APIHubConnector.GetTableMetadata(li...",

  "errors": [

    "-1",

    "Microsoft.SharePoint.SPConnectorException"

  ]

}

   at Anonymous function (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/js/AppMagic.Runtime.Client.js?v=2.0.79...)

   at q (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at O.enter (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at _run (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at _chainedError (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at c (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at then (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at I.enter (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at _run (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

   at _setCompleteValue (https://cdn-paaprodeus.azureedge.net/v2.0.791.67708169/studio/openSource/modified/winjs/js/base.js?v...)

 

Sessie-id: cb9e371f-a1f7-46b9-a451-44f54005189b

 

 Below is a screenshot, after clicking on the PowerApps button in the Sharepoint online (Office365) interface. The header in the popup is Dutch, which translates to: “there was an error while making the ….”, the button text “Sluiten” is “Close” in English, the header of the page (top left of page) translates to: “Making an app in Fugro (company name!) (default)”. As mentioned the field SAP-nummer is a lookup field from another list from the same site.

 

 Knipsel.PNG

Thanx again. Same happens when I try to create the app from within PowerApps Studio. Also browser IE, Edge or Chrome, doesn’t make a difference.

 

Pim Verver

 

 

 

 

Met vriendelijke groet, Pim Verver Dataprocessor p.verver@fugro.com | www.fugro.com Fugro NL Land B.V. Veurse Achterweg 10, 2264 SG Leidschendam | Postbus 63, 2260 AB Leidschendam, Nederland Handelsregisternummer: 27114147 | BTW nummer: NL005621409B08

Have you tried going to Connectors in PowerApps and see if there is any errors with the SharePoint connector?



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Hi Jeff,

 

Yes, the Sharepoint Connector shows 'Connected', so no problems there.

 

Incidentally, I can create an app from another list, which als has a Lookup field (with multiple selection possible). It doesn't show any errors, but when I want to change the fields visible, I cannot select the Lookup field, as it is not available as an option to select.

 

Weird he

HiJeff,

 

I have found the issue: when you select the lookup field (in List settings) as 'xxx (linked to item)', you get the error. When you select the field as is (without the hyperlink) it works.

 

But it works because it has no multiselect option.

 

The other list, which has a lookup field with the multiselect option, can't get selected to show in an PowerApp interface. Is that your experience also?

 

Kind regards,

 

Pim

Anonymous
Not applicable

I am also getting the error with a site column based lookup field on the item title column (no link to item etc), no multiselect:

 

{
"status": 400,
"message": "The required field \"Business Unit\" data type is not supported\r\nclientRequestId: 0947e2db-60a7-4e97-b189-4cb46cbeb222\r\nserviceRequestId: abf1529e-2027-5000-6d6a-60c804d03444",
"source": "***urlRedacted***sharepoint.com/sites/staffForms/Parking/_api/SP.APIHubConnector.GetTableMetadata(listName='f623845f-94ee-471d-8668-5b3b72c31432')",
"errors": [
"-1",
"Microsoft.SharePoint.SPConnectorException"
]
}
Stack: Core.ApplicationError: {
"status": 400,
"message": "The required field \"Business Unit\" data type is not supported\r\nclientRequestId: 0947e2db-60a7-4e97-b189-4cb46cbeb222\r\nserviceRequestId: abf1529e-2027-5000-6d6a-60c804d03444",
"source": "***urlRedacted***sharepoint.com/sites/staffForms/Parking/_api/SP.APIHubConnector.GetTableMetadata(listName='f623845f-94ee-471d-8668-5b3b72c31432')",
"errors": [
"-1",
"Microsoft.SharePoint.SPConnectorException"
]
}
at r.t [as constructor] (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/js/Core.js?v=2.0.820.69781359:1:677)
at r.t [as constructor] (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/js/Core.js?v=2.0.820.69781359:1:957)
at new r (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/js/Core.Services.js?v=2.0.820.6978135...)
at Function.r.createServiceError (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/js/Core.Services.js?v=2.0.820.6978135...)
at https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/js/AppMagic.Runtime.Client.js?v=2.0.8...
at Object.q [as _notify] (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/openSource/modified/winjs/js/base.js?...)
at Object.enter (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/openSource/modified/winjs/js/base.js?...)
at c.Class.derive._creator._run (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/openSource/modified/winjs/js/base.js?...)
at c.Class.derive._creator._chainedError (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/openSource/modified/winjs/js/base.js?...)
at c (https://cdn-paaprodseau.azureedge.net/v2.0.820.69781359/studio/openSource/modified/winjs/js/base.js?...)

Session ID: eb349cdd-9f70-4053-8b06-10f444b26b29

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,387)