cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Najwa_Rahal
Helper III
Helper III

Submit EditForm is not Updating my Sharepoint List Item

Hello, 

 

I have created a powerapp form a sharepoint list that has one item. Additionally, I have created a submit form linked to the list item. However, The EditForm is not updating the item in the list. Please see below my configuration.  ( for info the powerapp is embeded in the sharepoint site ) 

 

Your help is appreciated 

 

Screen Shot 2020-06-01 at 2.46.24 PM.pngScreen Shot 2020-06-01 at 2.45.55 PM.pngScreen Shot 2020-06-01 at 2.45.45 PM.png

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
mdevaney
Super User
Super User

@Najwa_Rahal 
You should put this code in the OnSelect property of your Submit button instead.

SubmitForm(Form1)

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Hello @mdevaney , 

 

I tried SubmitForm(Form1) and yet when I Edit the fields and submit the Form gets back the initial data prior to Edit. 

 

I feel that when I click submit the Form gets re-initialised with the original data of the item. is it because I have set the form to lookup for the item : 

LookUp(Scope,Title="Super") . 

 

As if when I submit my form , the above code runs and the form details gets re-initialized with the original data ? Or I am completely wrong ? 

 

Thank you. 

 

Najwa. 

View solution in original post

4 REPLIES 4
mdevaney
Super User
Super User

@Najwa_Rahal 
You should put this code in the OnSelect property of your Submit button instead.

SubmitForm(Form1)

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Hello @mdevaney , 

 

I tried SubmitForm(Form1) and yet when I Edit the fields and submit the Form gets back the initial data prior to Edit. 

 

I feel that when I click submit the Form gets re-initialised with the original data of the item. is it because I have set the form to lookup for the item : 

LookUp(Scope,Title="Super") . 

 

As if when I submit my form , the above code runs and the form details gets re-initialized with the original data ? Or I am completely wrong ? 

 

Thank you. 

 

Najwa. 

View solution in original post

@Najwa_Rahal 
Check your datasource.  Did the datasource update with the new values?

If yes, the form is showing the wrong data because you have not used the correct code in the Item Property of the form.  You can put this code in the OnSuccess property of your form

Set(currentRecord, Form1.LastSubmit.ID)

 

Then use this code in the Item property of your Form.

LookUp(your_datasource_name, ID = currentRecord.ID)

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

hi @mdevaney , 

 

Weirdly enough , I retried it now and it works . I think it required some time to get updated. 

 

Thank you for your help. 

 

Najwa. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,814)