cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ms-PowerRanger2
Advocate I
Advocate I

Submit Form Not Updating Back-end SharePoint List When Removing Data from a Field

I have a SharePoint List record that I'm updating via PowerApps. 

 

  1. If I update a field (like a date field) (by replacing the date with a new date), then submit the form, It updates the back-end SharePoint List
  2. If I update a field (like a date field) (by removing the current date and leaving blank), then submit the form, It does not update the SharePoint List

This seems to be an issue on our clients environment but not in our environment.

 

Any ideas on what to do or look for?

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User
Super User

@Ms-PowerRanger2 

In your App Settings, turn on the Formula level Error Management.  It's the only way you can write a blank value to the datasource currently.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

5 REPLIES 5
cds
Impactful Individual
Impactful Individual

I think if the field is required, SP wont accept a blank update.. 

RandyHayes
Super User
Super User

@Ms-PowerRanger2 

In your App Settings, turn on the Formula level Error Management.  It's the only way you can write a blank value to the datasource currently.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!
Ms-PowerRanger2
Advocate I
Advocate I

Thanks Randy!  That took care of it!  That's interesting that this setting is under the Experimental section.  I had it turned on in our environment and wondering if the setting may have not come through with the export and import of the Application.  (If this setting is suppose to stick with an export/import of an application, then I could have set it in our environment after exporting)

 

Thanks for the quick response!

Thanks for your fast reply.  The field isn't required but Randy Hayes suggestion of turning on the Experimental setting "Formula level Error Management" worked.

@Ms-PowerRanger2 

No problem.  Yes, it's quite possible the setting did not translate over to the other environment.  I'd always check through from one to the other whenever you import just to be sure.

 

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,336)