cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Submit Form not working on dynamic data source

I have datasource from excel serveral tables.
and I datasource of from as dynamic table link to dropdown.

but when I save data by SubmitForm(Form1). It's not working.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Submit Form not working on dynamic data source

Oops! sorry it's working fine

 

able to submit form now.

 

After I changed to assigned table with Set(tb,switch(...))

Previously I have assigned table by store multi tables in Collection.

View solution in original post

4 REPLIES 4
Anonymous
Not applicable

Re: Submit Form not working on dynamic data source

Hi @akario 

 

Is the Edit Form mapped on a single table for insert/update or how is it.

 

If its Edit Form, can you check the DataField & Update Properties of the DataCard.

 

Thanks.

Highlighted
Community Support
Community Support

Re: Submit Form not working on dynamic data source

Hi @akario ,

Please check:

1)whether the excel file was opening when you submitted the form?

2)did you set the right property to the dropdown?    (DropDown1.Selected.fieldname)

Do you have any error message?

Could you show your screenshoots or the settings of the form?

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Submit Form not working on dynamic data source

Show error message below

"There was a problem saving your changes. The data source may be invalid"

 

Due to I assigned table with below fx
Set(TBSc,Switch( LabelTable.Text,"Sb01",Tb01,"Sb02",Tb02,...)

 

and then I have set Data Source of EditForm1 as TBSc

 

once I run SubmitForm(EditForm1) 
the message above occure

Highlighted
Frequent Visitor

Re: Submit Form not working on dynamic data source

Oops! sorry it's working fine

 

able to submit form now.

 

After I changed to assigned table with Set(tb,switch(...))

Previously I have assigned table by store multi tables in Collection.

View solution in original post

Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,601)