cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lourenacdm
Helper III
Helper III

Submit Multiple Forms doesnt work

I have three screens from the same data source, I am using the submission form to send them, the problem seems that the forms are being saved in my data screen, but they are being multiplied, I don't know why, before these screens were in separate pages and did not work, just save the first, now I put all three on the same page and this error is occurring.

 

Lourenacdm_0-1620289829157.pngLourenacdm_1-1620290013120.png



Lourenacdm_2-1620290095905.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Lourenacdm,

My bad, the formula should be set for the OnSelect property rather than the OnSuccess property.

You just need to use the Patch formula on the OnSelect property inside the submit button.

Check for the above.

Regards,

Qi

Best Regards,
Qi

View solution in original post

4 REPLIES 4
v-qiaqi-msft
Community Support
Community Support

Hi @Lourenacdm,

Do you want to submit multi forms at a time?

Could you please tell me more about your scenario?

Actually, a single record will be created once you click a button to trigger SubmitForm(Form1). If you have another SubmitForm() fomula following behind, it does not make sense.

If you want to submit multi forms at a same time, you could consider the Patch() function.

Set the OnSelect property of the submit button as below:

 

Patch(DataSource,Defaults(DataSource),Form1.Updates,Form2.Updates,Form3.Updates)

 

Hope it could help.

Regards,

Qi

Best Regards,
Qi

So, I need to set a SubmitForm(Form1) inside the botton and then inside the OnSucess property from Form1 I will set the Patch function? 

Because in My botton I dont have the OnSucess Property

Hi @Lourenacdm,

My bad, the formula should be set for the OnSelect property rather than the OnSuccess property.

You just need to use the Patch formula on the OnSelect property inside the submit button.

Check for the above.

Regards,

Qi

Best Regards,
Qi

View solution in original post

It works, but when I'm going to use the forms to edit, it doesn't edit and creates a new field. Is it possible to use this for New and Edit Form?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,224)