cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi all, 

 

I made a PowerApp Form in one of my SharePoint lists. When I want to submit my form input, it keeps loading ... and I only see dots above the Form moving.... After 5 minutes the Form submits and get saved into my SharePoint list. 

Form keeps loading...... after 5 mins submit into shp listForm keeps loading...... after 5 mins submit into shp listMy PowerApp FormMy PowerApp Form

 

My question, is this an Performance issue? Everything on our side (also internet) seems okay. 

Or is there any settings in my PowerApps Form what I have missed to let the Form submits directly?? (onSave: SubmitForm(SharePointForm1 already in the App) 

 

Ofcourse Submitting a Form input and wait for 5 minutes is not acceptable, right? 

 

Any help should be fine! Thx in Advanced.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi Mona, 

 

Yesterday I tried to test again and everything seems works fine. The PowerApp form summits directly! So, I think this is an ‘internet’ hickup or so? Already tried a few days, also looking for many debugging and analysing methods.... and couldnt find. Finally tried to do a post in the community and asking for help via Twitter.... 

And now, it suddenly works Woman Sad

Anyways, many thanks for the willing of help! 

 

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi @MichelleWongNL ,

 

Please try to test with another list and another device. If the issue is specific to this list, then please check how many columns do you have for this form and is there any unusual column type or special setting in this list?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Submit a Powerapp Form keeps loading with dots... after 5 mins the Form submits. Is this an performance issue?

Hi Mona, 

 

Yesterday I tried to test again and everything seems works fine. The PowerApp form summits directly! So, I think this is an ‘internet’ hickup or so? Already tried a few days, also looking for many debugging and analysing methods.... and couldnt find. Finally tried to do a post in the community and asking for help via Twitter.... 

And now, it suddenly works Woman Sad

Anyways, many thanks for the willing of help! 

 

View solution in original post

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (5,196)