cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
QuYoussef
New Member

SubmitForm doesn't creat a Sharepoint item

Hi,

  First, sorry for my English and thanks for your help

  When I submit a form to create a Sharepoint list item from Power Apps, sometimes, rarely, commands listed in the field “on success” are executed, but the Sharepoint item isn’t created. I checked the FormMode and the DisplayMode, all seems Ok (Default FormMode on New and the form is initialised all the time by NewForm).

  I already had a look to some discussions on this forum, but I didn’t find the same issue. I can give more information if you have questions

 

  Thanks for your help

4 REPLIES 4
StalinPonnusamy
Community Champion
Community Champion

Hi @QuYoussef 

 

Can you set the OnFailure property of the form to

Notify(
    Concat(
        Errors(SPListname),
        Column & ": " & Message
    ),
    NotificationType.Error
)

 

If any errors, at least we can able to see. Is it happening all the time or any pattern?

 

 

 

 

Hello @StalinPonnusamy

 

  Thank you very much for your answer.

 

I will set the OnFailure as mentioned and give you a feed back.

I m almost certain that the OnSuccess only is executed because all the commands set in OnSuccess are executed and not those set in OnFailure.

 

There is no error message.

 

I tried to reproduce the issue but couldn't, I really expect that it happens randomly (It happened 5 times, the apps is used by 10-15 users since 6 months and the lists don't exceed 2000 lines...)

 

I think that we can rephrase the question as: When the SubmitForm don't creat a ligne in a Sharepoint list even if a form is a NewForm and even it returns OnSuccess ?

 

Perhaps servers slowdowns 

 

To maintain the app online, I now stock the title of the line to be created and creat a flow to check if done, advert me if not, but I think that the code in the OnFailure you gave is in the same philosophy 🙂

 

Regards,

 

StalinPonnusamy
Community Champion
Community Champion

Hi @QuYoussef

 

One thing we can do, Validation the inputs before Submit form() and On failure (If any Server failure/clutch) we can send it to Power Automate since it has retry automatically.

 

 

Tks @StalinPonnusamy

All the inputs are validated before submitting. I put a disabled button to submit which can't be enabled until the 6 data of columns are ok.

 

The thing is the form is submitted correctly, there is no OnFailure, but the line is not created in the SharePoint list! It's a little bit strange! And it happened only 5 times, all on October 5th between 11h22 and 11h32 GMT

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,442)