cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jladley
Frequent Visitor

SubmitForm error in Version 2.0.632 using SharePoint - Server Response: Invalid URL

Users of my PowerApp and myself are receiving an error when attempting to submit data from a form.  The form in connected to a Sharepoint list.  Our Sharepoint is not on prem it is cloud based Office 365.  In PowerApps I have tried:

  1. refreshing the Datasource (sharepoint list)
  2. removing and re-adding the Datasource (sharepoint list)

Neither of these changes have made the error message go away. The error message is on the OnSelect property of a button that submits the form.  The error says "An error occurred on the server.  Server Response: Invalid URL: jladley@tri-mgroup.com."  The Datasource property for the form is a SharePoint List. This was last known to be working yesterday (5/24/2017 11:31 AM) and I had not made changes to my application since then.  Has there been an update in version 2.0.632 that would cause this regression?  Has our licensing changed in any way that would cause this error?  Please advise on how I can fix this and get my app back into production.

 

Here is a screenshot of the error in the windows editor. 

powerApps_error3.png

 

Thank you,

Jason

1 ACCEPTED SOLUTION

Accepted Solutions
jladley
Frequent Visitor

This issue has been resolved.  Someone or some update changed the data type of the UserEmail field in our SharePoint list to Hyperlink or Picture.  This caused the SubmitForm function to fail because SharePoint was returning an error about the UserEmail field data being in the wrong format.  That's why I was seeing the message: "Server Response: Invalid URL: jladley@tri-mgroup.com."  I hope this helps someone else who might encounter the same issue.

View solution in original post

1 REPLY 1
jladley
Frequent Visitor

This issue has been resolved.  Someone or some update changed the data type of the UserEmail field in our SharePoint list to Hyperlink or Picture.  This caused the SubmitForm function to fail because SharePoint was returning an error about the UserEmail field data being in the wrong format.  That's why I was seeing the message: "Server Response: Invalid URL: jladley@tri-mgroup.com."  I hope this helps someone else who might encounter the same issue.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,858)