cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jladley
Frequent Visitor

SubmitForm error in Version 2.0.632 using SharePoint - Server Response: Invalid URL

Users of my PowerApp and myself are receiving an error when attempting to submit data from a form.  The form in connected to a Sharepoint list.  Our Sharepoint is not on prem it is cloud based Office 365.  In PowerApps I have tried:

  1. refreshing the Datasource (sharepoint list)
  2. removing and re-adding the Datasource (sharepoint list)

Neither of these changes have made the error message go away. The error message is on the OnSelect property of a button that submits the form.  The error says "An error occurred on the server.  Server Response: Invalid URL: jladley@tri-mgroup.com."  The Datasource property for the form is a SharePoint List. This was last known to be working yesterday (5/24/2017 11:31 AM) and I had not made changes to my application since then.  Has there been an update in version 2.0.632 that would cause this regression?  Has our licensing changed in any way that would cause this error?  Please advise on how I can fix this and get my app back into production.

 

Here is a screenshot of the error in the windows editor. 

powerApps_error3.png

 

Thank you,

Jason

1 ACCEPTED SOLUTION

Accepted Solutions
jladley
Frequent Visitor

This issue has been resolved.  Someone or some update changed the data type of the UserEmail field in our SharePoint list to Hyperlink or Picture.  This caused the SubmitForm function to fail because SharePoint was returning an error about the UserEmail field data being in the wrong format.  That's why I was seeing the message: "Server Response: Invalid URL: jladley@tri-mgroup.com."  I hope this helps someone else who might encounter the same issue.

View solution in original post

1 REPLY 1
jladley
Frequent Visitor

This issue has been resolved.  Someone or some update changed the data type of the UserEmail field in our SharePoint list to Hyperlink or Picture.  This caused the SubmitForm function to fail because SharePoint was returning an error about the UserEmail field data being in the wrong format.  That's why I was seeing the message: "Server Response: Invalid URL: jladley@tri-mgroup.com."  I hope this helps someone else who might encounter the same issue.

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,857)