cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

SubmitForm function can only work on a form. Wrong kind of control input is given...

All of a sudden, the Submit button stops working, producing this error:

 

paerror.png

 

It was working fine and I changed NOTHING in my EditForm.

 

This is a custom button. The original tick in the upper right corner with exactly the same formula/settings works just fine.

 

Any idea?

55 REPLIES 55
Highlighted
Anonymous
Not applicable


@GrischkePro wrote:
I restored my app to when PowerApps was .14 and it works. I haven’t made that many changes. I’m in meetings today so needed to get it working.

Hmm yeah that might work if you only wanted to use your app. But it's no good if you're still developing it. As soon as PowerApps makes an automatic save it will update the version again.

 

..unless I'm missing something?

Highlighted

That’s correct, I’ll have to keep it unchanged for now, but I’m not reprogramming all submit buttons...
Highlighted
Anonymous
Not applicable

I have a similar issue with th ResetForm function. Control is definately a form.

Error.jpg

No problem yesterday but after upgrade to 3.19062.18 today I have this issue.

And that is not the biggest issue that has suddenly popped up. But I'll create another thread for that one.

 

Highlighted

I have a the same issue with SubmitForm Its started from 3.19062.18 version. When I downgrade my forms on ...14, all forms is OK.

 

that's a bug.

I hope microsoft comes with a fix.. Miro, QPC

Highlighted
Advocate III
Advocate III

Hi all, 

Just to add my voice to this bug as well. I have form functions calling aform from another form, which I have embedded in an icon on form 1 calling NewForm(Form2)

Needless to say it is not working.

A quickway around this is to add in a button that IS NOT on a form.

But this just wont work. I need a button on each row of data in that form.

 

This issue obviously presents a problem for us as this is a production app, which if I roll back, I will loose my recent edits, but now the users cannot use the app.

Any updates on when this is will be looked into?

 

Thanks, 

Andrew

Highlighted
Advocate I
Advocate I

Any idea when this might be working? causing real issues for developing...is there anywhere i can check a service update on this from microsoft?

Thanks

Highlighted


@rachelkettle wrote:

Any idea when this might be working? causing real issues for developing...is there anywhere i can check a service update on this from microsoft?

Thanks


This needs to be fixed super urgently. We can't be waiting a week for another update...

 

I wish I knew Microsoft has actually acknowledged it.

Anonymous
Not applicable

I hope it gets fixed soon. Business is at a standstill here. The higher ups have asked me to research alternatives to PowerApps, non-Microsoft alternatives. Even getting off Azure for the entire company. Huge headache for me.

Highlighted

I have logged a support ticket so will update on any responses...fingers crossed this is resolved ASAP!

Highlighted


@rachelkettle wrote:

I have logged a support ticket so will update on any responses...fingers crossed this is resolved ASAP!


How did you raise a ticket? Via the admin portal?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,457)