cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GrischkePro
Advocate III
Advocate III

SubmitForm function can only work on a form. Wrong kind of control input is given...

All of a sudden, the Submit button stops working, producing this error:

 

paerror.png

 

It was working fine and I changed NOTHING in my EditForm.

 

This is a custom button. The original tick in the upper right corner with exactly the same formula/settings works just fine.

 

Any idea?

55 REPLIES 55


@ADobin wrote:

Thanks for all of the reports on this issue! We've released a fix and this should be resolved now.


Good.

It would be nice to know that you were actually working on it.

 

I can confirm it works fine now on version: 3.19062.20.👍🏼

netmarie
Advocate I
Advocate I

Another related issue?  I confirmed Saturday that the SubmitForm issue was resolved only to bump heads with another new issue.  The save is successful but OnSuccess event is not appear to perform all included steps.  It is supposed to Refresh the data source (from SQL) and ClearCollect to update the collection, but that is not happening.  It was working properly before the issue with SubmitForm.   


@ADobin wrote:

Thanks for all of the reports on this issue! We've released a fix and this should be resolved now.


Knew you'd find a fix for this!

I can confirm from my end that everything is working as expected again.

 

Thank you!

-M

Hi @netmarie , you shouldn't have to refresh your collection and follow it with clearcollect.

You should be able to just clearcollect. But since you mentioned you are using a form, after you submit any form, you have access to the latest updated record.

Form.LastSubmit.

Just update your collection with this or use it however you'd like! But its a less expensive operation then refreshing your data source. Good luck!

Yes I know all that, thanks though.  My form is connected straight to a SQL table and populated based on the selected row of a gallery, which is linked to a collection.  The collection is built from a SQL view which joins multiple tables.  When the form is saved, it is easiest to refresh the SQL view and rebuild the collection.  This has been working for months but stopped after the SubmitForm issue was resolved.  I went ahead and patched the collection instead, which is fine for that screen but multiple other screens need to be updated as well, and those Refreshes aren't working properly either.  A Microsoft technician witnessed the issue yesterday and is investigating.    

Hi @GrischkePro ,

Has your problem been solved?

If you do not have any other problem, please mark one answer as your issue's solution.

Thanks!

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,849)