cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

SubmitForm function can only work on a form. Wrong kind of control input is given...

All of a sudden, the Submit button stops working, producing this error:

 

paerror.png

 

It was working fine and I changed NOTHING in my EditForm.

 

This is a custom button. The original tick in the upper right corner with exactly the same formula/settings works just fine.

 

Any idea?

55 REPLIES 55
Highlighted


@ADobin wrote:

Thanks for all of the reports on this issue! We've released a fix and this should be resolved now.


Good.

It would be nice to know that you were actually working on it.

 

I can confirm it works fine now on version: 3.19062.20.👍🏼

Highlighted
Advocate I
Advocate I

Another related issue?  I confirmed Saturday that the SubmitForm issue was resolved only to bump heads with another new issue.  The save is successful but OnSuccess event is not appear to perform all included steps.  It is supposed to Refresh the data source (from SQL) and ClearCollect to update the collection, but that is not happening.  It was working properly before the issue with SubmitForm.   

Highlighted


@ADobin wrote:

Thanks for all of the reports on this issue! We've released a fix and this should be resolved now.


Knew you'd find a fix for this!

I can confirm from my end that everything is working as expected again.

 

Thank you!

-M

Highlighted

Hi @netmarie , you shouldn't have to refresh your collection and follow it with clearcollect.

You should be able to just clearcollect. But since you mentioned you are using a form, after you submit any form, you have access to the latest updated record.

Form.LastSubmit.

Just update your collection with this or use it however you'd like! But its a less expensive operation then refreshing your data source. Good luck!
Highlighted

Yes I know all that, thanks though.  My form is connected straight to a SQL table and populated based on the selected row of a gallery, which is linked to a collection.  The collection is built from a SQL view which joins multiple tables.  When the form is saved, it is easiest to refresh the SQL view and rebuild the collection.  This has been working for months but stopped after the SubmitForm issue was resolved.  I went ahead and patched the collection instead, which is fine for that screen but multiple other screens need to be updated as well, and those Refreshes aren't working properly either.  A Microsoft technician witnessed the issue yesterday and is investigating.    

Highlighted

Hi @GrischkePro ,

Has your problem been solved?

If you do not have any other problem, please mark one answer as your issue's solution.

Thanks!

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (7,953)