cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

SubmitForm "The data source supplied to function is invalid."

This morning have been having issues loading my app if I open and close my browser a few times it finall works.   When I try and submit a new form it errors out with the following.  The data source supplied to function is invalid.  I remove the data soruce added back in and still get the same error.   I've removed the data soure then added it back with the same issues.

 

SubmitForm The data source supplied to function is invalid.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper III
Helper III

Re: SubmitForm "The data source supplied to function is invalid."

I came in this morning and launch the same App with NO issues never mad any changes it's working like it should.   

View solution in original post

5 REPLIES 5
Highlighted
Anonymous
Not applicable

Re: SubmitForm "The data source supplied to function is invalid."

What is the data source?

Have you made an empty app and written to the data source from a form?
Highlighted
Helper III
Helper III

Re: SubmitForm "The data source supplied to function is invalid."

Just tested and that works.   But can't get it to work in my existing from Fiddler I'm getting HTTP/1.1 204 No Content error when trying to submit the data..   I can view the data from the app but I can not update or create new.  

Highlighted
Community Support
Community Support

Re: SubmitForm "The data source supplied to function is invalid."

Hi @gbuhre ,

Please refer this doc to check whether you use right way to update data:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/working-with-forms

Please try to clear your browser's cache and update it to the latest version.

If the problem still exits, try to recreate your app.

 

Best regards,

Community Support Team _ Phoebe Liu

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper III
Helper III

Re: SubmitForm "The data source supplied to function is invalid."

I came in this morning and launch the same App with NO issues never mad any changes it's working like it should.   

View solution in original post

Highlighted
Helper III
Helper III

Re: SubmitForm "The data source supplied to function is invalid."

Hi, 

 

I realized that today is the nth time that I get this error.

 

function is invalid errorfunction is invalid error

This issue will get resolved by re-typing the codes.  Same codes. But I cannot cut and paste. I have to retype.

I would open the app to edit some colors (or very small edits) but everytime I open this to edit - I just get these red X with that same error in the picture. 

My worry is : what if one day, that error will exist when its time for us to use the app at the same time, re-typing the code isn't the solution anymore? 

 

Is there another way to resolve this?

 

Thank You, 

KH

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (12,781)