cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rackabajsarn
Frequent Visitor

Submitform/patch SQL fail

Hi,

I'm having problems changing or deleting a record from SQL using patch/submitform/remove. I have a feeling it might be related to me having non-english characters in my primary key column-name.. It might also be that I'm using an email as PK? See attached screenshots for error codes.

 

Just to try it, I'm using the auto-generated "start from data"-app. When I try another table with PK being just INT and column name "ID", there is no problem. I tried to change the column name in my table, but powerapps doesn't seem to want to update the table indexing. This gives me an error where powerapps is looking for the old column name. I'm guessing I have to remove data source for it to update?

 

Before I start the long journey to fix this, does anyone have an idea that will ease my pain?

 

Best regards,

Daniel

 

1 ACCEPTED SOLUTION

Accepted Solutions

It was as I expected, the "ä" in my PK f*d it all up. In other columns it's alright though. Thanks for the tip @AndySid, I must have tried everything except that:)

View solution in original post

2 REPLIES 2
AndySid
Resolver II
Resolver II

I often have to refresh the data source when making tables changes, in view - data soruces, select and refresh

It was as I expected, the "ä" in my PK f*d it all up. In other columns it's alright though. Thanks for the tip @AndySid, I must have tried everything except that:)

View solution in original post

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,557)