cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wordsmither
Frequent Visitor

Sudden appearance of red x's

Today, when I opened up my powerapps app, I'm presented with a ton of red x's.  It appears to save and publish fine, but any ideas whats going on?

 

2019-02-22_11-11-46.jpg

1 ACCEPTED SOLUTION

Accepted Solutions

@wordsmitheryou didn't mention, but it looks like this is a SharePoint data source.

If it comes and goes, I would expect there is something to do with the connection or the way that you are using it. 

Is the form's datasource JUST your SharePoint list, or are you doing something else to collect and display?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

57 REPLIES 57
RandyHayes
Super User
Super User

@wordsmitherdid you look at the errors that are behind the red x's?  You can click on them individualy to see where the error is or use the App Checker - personally I'd use the click on the X and see method.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Sorry I didn't include that.  The message for all of them is "The Data source Supplied to the function is invalid".

 

Thing is, nothing has changed with the data source.  and sometimes, all the errors go away.  Its all very odd.

@wordsmitheryou didn't mention, but it looks like this is a SharePoint data source.

If it comes and goes, I would expect there is something to do with the connection or the way that you are using it. 

Is the form's datasource JUST your SharePoint list, or are you doing something else to collect and display?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Yes, just a SharePoint list.  I suspect there was just some temporary issue with connecting to the source that appears to have gone away.  Just scared me!

pvanolinda
Advocate II
Advocate II

This just started happening to me today and it caused several of the SharePoint choice fields we use in our apps to stop working!! Specifically, in choice fields the dropdown options don't show up and for person/group fields it doesn't come up with suggestions when you begin typing a username. I logged a call with Microsoft and they said it's a known issue caused by the Product team releasing updates. Now every time I go in and edit an app the red crosses appear in 'Choice' and 'Person or Group' fields until I refresh the SharePoint list under View > Data Sources. They said it would just 'go away' eventually. This is a major fault that needs to be addressed seeing that it breaks the app functionality. Can anyone from Microsoft provide an explanation and update as to when this might be fixed? Thanks!

ASAP I am having the same issue. The view->Data refesh is not working. When is this suppose to be fixed?

I have a list bound to  powerapps in production.

Anonymous
Not applicable

I have the same issue, and we are losing business value due to this

MickThornton
Advocate II
Advocate II

The only times I've ran into the red Xs on my forms is when I've changed (or someone else changed) the underlying SharePoint list by adding a field, messing with the content type, or adding/removing from a choice field.  Are others seeing the red X without ANY underlying changes to SharePoint?

Vinoj3683
New Member

I am facing the same issue with CDS.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (3,845)