cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Sudden appearance of red x's

Today, when I opened up my powerapps app, I'm presented with a ton of red x's.  It appears to save and publish fine, but any ideas whats going on?

 

2019-02-22_11-11-46.jpg

42 REPLIES 42
Anonymous
Not applicable

Any news on this topic? I had just build a nice form. After i add two new look up columns al my columsn are not working anymore, very very strange. I just deleted the datasource and remove/add all the code for the items. I doenst look this will fix the error.

 

Has someone registered a ticket by Microsoft for this?

Frequent Visitor

This is becoming so frustratingly annoying, just another person having an issue with Powerapps.

And its been an issue for several months. Every time i open a form i have to refresh data source and then rebind ["value"] in all complex fields...

@pvanolinda @msspdev @gmaasz @Vinoj3683 @LouisaDW @johnom @Monty_Baird @WilliamVingaard @Anonymous @Anonymous @longathrow Hi all--sorry for the inconvenience this is causing.  We have identified what we believe to be the root cause of the issue and are currently validating a few.  It should be available shortly for release to production.

As we understand it, the issue may occur sometimes when the data source that a ComboBox control is bound to is either (a) refreshed, or (b) removed and then added again.  The current advised mitigation that has seen success with customers is to perform the following actions after refreshing or removing/adding a data source:

  1. Save the app immediately and close it
  2. Re-open the app and continue making any non-data source refresh/remove/add changes (note: you will have to make at least one trivial change to mark the app as dirty so that it can be saved again in step #3)
  3. Save the app and re-publish

This should allow the ComboBox controls to be correctly reconfigured to the correct values.

Also, if your ComboBox control contains only a small number of values, it is advised to disable IsSearchable since (a) this incurs a slight overhead when enabled, and (b) the issue of empty values only occurs when IsSearchable=true.

 

Anonymous
Not applicable

This works perfect for me, i see nog meer red X's since i use this solution 🙂

this saved lot of my time ....it was always annoying

Update: We have committed a fix that we believe will resolve this issue.  It is currently expected to be deployed to all production regions during the week of October 21st.  I will update this post again once it has been deployed.

This actualy solved my problem. Thx Monty

@pvanolinda @msspdev @gmaasz @Vinoj3683 @LouisaDW @johnom @Monty_Baird @WilliamVingaard @HillaRamo @Wackmack88 @longathrow @ravievg @irawanfajar The fix for missing items in ComboBox drop-downs has been deployed to all production regions with Studio release 3.19101.  You will need to edit and re-publish your app(s) for the changes to take effect.

@_Corey_ This solution worked 4 hours ago when you posted it, but now my app is showing the red x's again and the following the same solution procedure does not fix it.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,740)