cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Suspected new bug - Sharepoint Onsave only firing once for new records

Hi everyone,

 

Have run into a very strange bug that has only started this week.  I have a powerapp based on a sharepoint list, with extensive logic in the onsave event to validate overall data entry before submitting form.  This takes the form of lots of standalone IF statements that each throw various Notify messages for errors before setting a varSaveNotOK flag inside each IF.  Form is only submitted when it falls through all the if statements and varSaveNotOK is never set.

 

This setup gave the user an opportunity to correct the data entry error and then press save again to resubmit.  Up until last week this process worked fine.  Starting this week, the user can still save a new entry if there are no data entry errors BUT if they make a mistake and a notify statement fires, the onsave button becomes totally unresponsive from then on.  I incremented a variable in onsave event to prove the save button click only works once.  The only option for user is to press cancel and then new button again and then they can only save if they do not make a mistake.

 

To prove this is a bug I reverted back to previous version from last week where extensive testing was done to prove all the validations were working.  Previous versions now also have the same problem from a known point in time where this was not happening.  I have obviously tried clearing cache, different browsers, even different machines that have not run the app before, same problem.

 

Interestingly if you edit an existing item and then change a field to an invalid value, you can attempt to save and be thrown notify messages all day.  The save button keeps working.  But when on a new item / form, the save button only ever works once, and never works again.

 

Obviously this is extremely frustrating and would appreciate any insight you might have into this issue.  Is this a bug??

 

Thanks in advance!!!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi everyone,

 

Have received confirmation from Microsoft that the fix has been deployed and I have confirmed save button is now working again as intended.  (for my tenancy at least).

View solution in original post

10 REPLIES 10
Advocate I
Advocate I

In addition to above, I was able to recreate the issue with a new list as follows:

1. Create a new default sharepoint list and customise forms. 

2. Commented out SubmitForm(SharepointForm1) and replaced it with Set(varTest, varTest+1). 

3. varTest initialised to zero in OnNew event.

4. Added a label to the default form to track value of varTest

Results:

1. When pressing new in sharepoint, varTest can only be incremented once when pressing the save button

2. When editing existing item, varTest can be incremented unlimited times

 

Definitely seems to be a new bug in sharepoint integration considering this functionality was working last week.

Any PowerApps devs able to confirm???

 

@cloudsurfing Did you get anywhere with this? My app also stopped working because the save could not trigger more than once when validating fields.
I had to temporarily create buttons and copy the code to their OnSelect property. hopefully someone from microsoft responds to this post, it will be good to know if this is going to now be the expected functionality of the OnSave or the are working on fixing the issue

Hi @Gottijay2000 , I also used the same workaround as you for now.  I have logged a support ticket with the PApps team and the level 1 support person has been able to replicate the issue.  I was advised they will log an internal ticket with the product team but I have not had confirmation that this has happened yet.  I personally think this is a bug rather than new expected functionality as the behavior during edit is unchanged plus this would break a whole lot of apps that are already out there.  I also can't see how effective validation could be done any other way than allowing this button to continue as it was.

 

Will update this topic once I hear anything back.

Frequent Visitor

I also ran into with this bug and find out that onSave event in PowerApps form runs only once, after first press of save button. Following pressing of this button do nothing. I have this behavior on two different tenants. My form was done few mounts ago and works good, onSave fires after every press of Save button.

Also find out that on edit form this event fires every time after pressing Save button

Version of my PowerApps form is 3.20023.8.

Is it confirmed bug? How to avoid this problem?

Frequent Visitor

I also ran into with this bug and find out that onSave event in PowerApps form runs only once, after first press of save button. Following pressing of this button do nothing. I have this behavior on two different tenants. My form was done few mounts ago and works good, onSave fires after every press of Save button.

Also find out that on edit form this event fires every time after pressing Save button

Version of my PowerApps form is 3.20023.8.

Is it confirmed bug? How to avoid this problem?

I also ran into with this bug and find out that onSave event in PowerApps form runs only once, after first press of save button. Following pressing of this button do nothing. I have this behavior on two different tenants. My form was done few mounts ago and works good, onSave fires after every press of Save button.

Also find out that on edit form this event fires every time after pressing Save button

Version of my PowerApps form is 3.20023.8.

Is it confirmed bug? How to avoid this problem?

Hi @AntonKovbych and @Gottijay2000 ,

 

I have received update from MS advising this is definitely a bug and related to something changed by Sharepoint team in late March to stop multiple new records being created in another scenario.  I am now awaiting ETA for hotfix which will be produced by the Sharepoint support team.  I will share details when I have them.

Anonymous
Not applicable

Any news about this issue? Were in trouble because of this… 😥

Hi @Anonymous , I just received this morning confirmation that a fix has been developed and will be rolled out across all world data centers within the next 2 weeks.  I will advise once I have confirmation this has been completed.

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (7,213)