cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jhall_IUH
Helper I
Helper I

Teams App - SharePoint Connector - Not prompting for Site

As a part of migrating some of our existing applications and trying out Dataverse I created a Teams App and associated Dataverse Table intending to connect to both a SharePoint List (that is within the same Team's SharePoint site) and a Dataverse Table.  This was just an initial test to ensure I can connect to both datasources.  However, I can't seem to connect to SharePoint.

 

Clicking to Add data and Connectors gets me to the following:

 

jhall_IUH_0-1611338076634.png

When I select the Office 365 Users Connector, I can select the existing Connection I created as a part of this process and it is added to the app just fine.  However, when I click SharePoint and select the existing SharePoint Connection I also created, it just keeps opening new Connection windows over and over.  It never prompts me for the SharePoint site to connect to.

 

I even popped into the PowerApps Admin panel to look around and see if I needed to configure something there, but just am not finding it.  The Connection(s) exist and are shown within the Teams Environment, but it never asks me for the Site/List to connect the SharePoint Connector to.

 

Thoughts?

1 ACCEPTED SOLUTION

Accepted Solutions
Pstork1
Dual Super User III
Dual Super User III

It looks like this is a bug when using the Teams Desktop client.  I was able to reproduce it there.  As a workaround if you open Teams in a Browser session and edit the Power App there you can add the SharePoint connection normally. I've reported it to the Microsoft product team and they are looking into it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

1 REPLY 1
Pstork1
Dual Super User III
Dual Super User III

It looks like this is a bug when using the Teams Desktop client.  I was able to reproduce it there.  As a workaround if you open Teams in a Browser session and edit the Power App there you can add the SharePoint connection normally. I've reported it to the Microsoft product team and they are looking into it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

secondImage

Power Apps Community Call

Please join us on Wednesday, October 20th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,025)