cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Test Studio fails using SharePoint lookup table values

Hi - 

 

I have an app that assigns a link between two records by using a SharePoint Lookup table as the field type.  Record A has a Project Name and a Parent Program Name.  The parent program comes from a different list than the project.  

 

In Test Studio I have a script to create the Program and one to create the project.  Then I have a script to associate the program to the project.  This all works fine.  But since this is a test scenario I finish by deleting the project and the program.

 

when I run the script a second time, the parent program has the same name but in SharePoint it has a new ID value.  So when the scenario tries to run a second time it fails on the association since the record (ID: xxx  Value: xxxx) do not match anything in the SharePoint list.  

 

Is this a scenario that PowerApps Test Studio should support?  am I doing something or not doing something?  Any advice is welcome.

DDucolonSBUX_0-1626466144528.png

 

SetProperty(AlignParentProgramDCValue.SelectedItems, Table({'@odata.type':"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference",Id:1030,Value:"zzz35-Auto PM test studio run PRG 001 Canada"}))
0 REPLIES 0

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Apps Ideas

Check out the New Ideas Site

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (5,180)