cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
MaxDonen
Level: Powered On

Text() function doesn't appear to work

Not sure whether this is due to a recent powerapps update, but I simply cannot get the text() function to work to format currency correctly. 

 

The data originates from a static excel spreadsheet. I have tried all kinds of formatting to get the numbers to display correctly. 

 

Interesting note: If I incorporate any math into the formula, it works perfectly. So the following formula actually works fine, but is a peculiar workaround:

 

Text(Cost*1/1,"[$-en-US]£#,###.00")

 

Is there a more direct fix? 🙂 

 

Thanks. 

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User
Dual Super User

Re: Text() function doesn't appear to work

Based on my testing @timl is correct.  The value is coming in from Excel as a string and that's why the Text formatting isn't working.  put a Value() function around the incoming cell and it should work.  That would also explain why adding math fixes it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

3 REPLIES 3
Super User
Super User

Re: Text() function doesn't appear to work

Hi @MaxDonen 

It could be because PowerApps has recognised the Cost field as a text field.

To test this theory, could you try this?

Text(Value(Cost),"[$-en-US]£#,###.00")

 

SG42
Level: Powered On

Re: Text() function doesn't appear to work

Hello

Have you tried with the language ?  

 

 

Text(Cost,"[$-en-US]£#,###.00" , "en-US")

 

 

I've used the Text() to format currencies yesterday from a SharePoint list and your formula works on my PA (maybe Excel file or value is the cause ?)



Dual Super User
Dual Super User

Re: Text() function doesn't appear to work

Based on my testing @timl is correct.  The value is coming in from Excel as a string and that's why the Text formatting isn't working.  put a Value() function around the incoming cell and it should work.  That would also explain why adding math fixes it.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,584)