cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Commander
Kudo Commander

TextInput Display mode bug

Hi,

I often use the display mode property of a textbox to allow/disallow editability of a textfield. This has worked without issue in the past however I recently check my app to find that all my text inputs were filled with "X" marks where I have set the display mode to disable.  I have shown an example below:

 

 

The x marks do not appear in the online developmetn enviroment but appears in the web browser when the app si deployed. I have run a basic test to show this. I can also note that the X does not appear when runnig the app on ios or IE but occurs in chrome.

 

Is this a new "Feature"? if so how can i remove it so users can actually view the content of the textinput?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Kudo Commander
Kudo Commander

Re: TextInput Display mode bug

It seems your response has help me find a work around. By setting the "Clear" function of a TextInput from the default "true" to "false" the "x" will not show.

 

image.png

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: TextInput Display mode bug

Hi @AnthonyPhan,

 

Thanks for the Feedback.

This should be related with the 'Clear' function of the TextInput Box. 

I tested this under Chrome with PowerApps Studio for Web, the 'X' would be kept there after DisplayMode switched to Disabled mode.

 

Basically if we have anything entered in the TextInput, there would be a 'X' available at the right side of the TextInput Box, which on clicking, it will remove the whole string entered, and the 'X' would disappear once the selection switched away from the TextInput.

 

I will do some more tests and report it from my side.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Kudo Commander
Kudo Commander

Re: TextInput Display mode bug

It seems your response has help me find a work around. By setting the "Clear" function of a TextInput from the default "true" to "false" the "x" will not show.

 

image.png

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (9,344)