cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper III
Helper III

The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi, PowerApps Team,

 

I am using the latest PowerApps version 3.18042.20. I have a field "Item_Qty" with data type of int. I would like it to have a default  of null deliberately set. Otherwise, the value could be carried over from other records in different form. In the data card for this field, I used "" for the default instead of "ThisItem.Item_Qty".

 

This setup works out fine in the edit mode, but when I ran the app in the "Play" mode, I encountered two problems; (1) instead of null value in the field, it got a value of zero (0) showing up, and when I tried to enter a value (other than 0), it would not take it. It looked like this field would not take any input from the keyboard. This is a required field, and the form couldn't be submitted as a result.

 

In summary, the app in Edit mode works, and the app in "Play" mode does not work. This means I can create an app for myself, I can't share it with others. In the past I have had occasions that the behaviors of the app have been different between Edit and Play mode. 

 

Can you offer some help?

 

 

66 REPLIES 66
Anonymous
Not applicable

@shekz any update on this or eta to fix?

1. Issue with null values getting converted to zeroes
Latest: Undergoing investigation. Will update once I have more info.

2. While trying to submit a form, the user gets this error “An entry is required or has an invalid value. Please correct and try again”

Latest: we have a fix, and are working to get it shipped ASAP; hoping in next 1-2 days.

3. Collections and onStart not behaving well and failing with error Invalid Mashup Expression

Latest: @Anonymous Had a discussion with the dev who's been looking into this. Could you please try this?

After all your OnStart rules, add “; Navigate(Screen1)”

 

 

Anonymous
Not applicable

3. Collections and onStart not behaving well and failing with error Invalid Mashup Expression

Update: tried adding "Navigate(Main_Screen,None" but error still remains.

 

Seems like this does not work either. The expected behaviour still works fine in "Edit" mode. Still just "Play" mode it is not working.

 

I am convinced this issue relates to the Session details in "Play" (go to setting > session details). In "Play it states "PowerApps 3.18043.18". In App details (before "Play") it states my latest version is "3.18043.22".

Frequent Visitor

Is there an update or workaround for this yet as my app is needed urgently and currently is does not work due to this error.

@Anonymous - Just updated my colleague that the suggested change isn't working. Will get back to you with more details soon.

cc: @erga

Updates:

 

1. Issue with null values getting converted to zeroes
Latest: In order to mitigate this issue, please set the DataCard's Default property (DataCard.Default) to `Blank()` rather than `""`. What appears to be happening is that the empty string ("") is considered invalid, so it's being converted to a Number, which is 0. By explicitly setting it to the `Blank()` PowerApps function, a `null` value is assured. Please let us know if this helps mitigate the issue.

 

2. While trying to submit a form, the user gets this error “An entry is required or has an invalid value. Please correct and try again”

Latest: Fix was deployed yesterday. Could ya'll please confirm if this works fine?

 

3. Collections and onStart not behaving well and failing with error Invalid Mashup Expression

Latest: @kyle705 I've requested @erga to help you.

Frequent Visitor

Howdy,

 

I think it is working, I just submitted a form with the new version and it didn't give me an invalid error. Good work and thanks for the quick response.

Thanks @JakeG for checking, and confirming. Glad, our team was able to help.

Happy PowerApp'ing 🙂

Anonymous
Not applicable

@shekz - The update is working for us - Thanks!

Shekz,

 

Here is my test for your suggestion below:

 

1. Issue with null values getting converted to zeroes
Latest: In order to mitigate this issue, please set the DataCard's Default property (DataCard.Default) to `Blank()` rather than `""`. What appears to be happening is that the empty string ("") is considered invalid, so it's being converted to a Number, which is 0. By explicitly setting it to the `Blank()` PowerApps function, a `null` value is assured. Please let us know if this helps mitigate the issue.

 

The Blank() does work to set the field int to null in your new software release, thanks. I have one more request, the Blank() does not work to set the datetime field to null, do you have other syntax / trick to set the datetime field to null? This request has been posted a long time ago in PowerApps user community.

 

We (users) need the ability to set any fields with any datatypes to null, this is absolutely required for the development of the PowerApps applications!!!

 

 

Thanks.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (10,901)