cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Power Apps
Power Apps

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

CC: @AllenKim who was investigating the issue.

Highlighted
Power Apps
Power Apps

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @Anonymous,

 

Looking at your session, it looks like we do make a blocking OnStart call. I see an error returned by the call to your SQL connection. The SQL service is returning an error status 400 and returns an error message "The column 'Col...tus' of the table wasn't found." Please note that I removed the middle part of your column name.

 

Can you try refreshing your data source in the authoring experience (View tab in the ribbon -> Data sources button -> '...' next to your SQL data source -> Refresh). This will grab the latest schema of your SQL table, as it seems that the schema your app has may be out of sync.

 

Thanks,

Allen

Highlighted
Power Apps
Power Apps

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @Jswanson

 

Thank you for providing the session IDs. I looked at both of the sessions and based on the telemetry, it looks like we are still not blocking on the OnStart rule finishing even though you added a 'Navigate()' function call to the end of the OnStart rule. Rather than going back and forth, it would be great if we can just work directly to investigate the issue. Would you be willing to create a support ticket to make this possible? If so, please go to https://powerapps.microsoft.com/support/ and click on the "Create support ticket" at the bottom of the page to get started. I'll contact the folks that look at the incoming tickets to be sure to route the ticket to me when they see it.

 

Thanks,

Allen

Highlighted
Advocate II
Advocate II

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

I opened a ticket #118050118099541

Highlighted
Anonymous
Not applicable

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi

 

I did what was suggested in term of updating SQL schema.

 

Still not working unfortuntely.

 

Kind regards,

Kyle

Highlighted
Power Apps
Power Apps

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @Anonymous,

 

I am investigating why the call to get your items from certain SQL tables is returning errors about columns not being found. Just looking through some past calls to your SQL tables, I can see that there are failed calls as well as successful calls (but the failed calls outweigh the successful ones). If you refresh your SQL tables after the app is loaded, does the data load without errors?

 

Thanks,

Allen

Highlighted
Power Apps
Power Apps

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi @Anonymous, I believe you have a ticket open for the failing SQL calls. I chatted with my colleague who is looking at your ticket and it seems like that is the issue that is blocking your app right now. Can you see if the Explicit Column Selection app setting is enabled for your app? You can find this app setting by opening your app for edit then going to File -> App settings -> Experimental features -> Explicit Column Selection. If it is enabled, can you try disabling this setting, saving, publishing, and opening the app again?

Highlighted
Anonymous
Not applicable

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

Hi

 

That seems to have done the trick! No errors when starting app & I am seeing what I expect to see Smiley Happy

 

Thanks very much for your help.

 

Kind regards,

Kyle

Highlighted
Advocate II
Advocate II

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

App is working now!

Thank to the Team @Microsoft for working with me to take care of the issue.

Highlighted
New Member

Re: The PowerApps app works in edit mode, but not in "Play" mode, I can't share the app

@Jswanson

I am having a similar problem to yours.

 

In play mode my dropdowns populate fine. In the published mode the dropdowns are empty.

 

What did you do to correct the problem?

 

Thanks!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (6,640)