cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
muralikrishna12
Helper V
Helper V

The Specified record was not found/Resource not found error during patch

Hi Mates, 

how to resolve this issue,

I just extended column length from Varchar(50) to Varchar(500), then I refreshed SQL DataBase, the table in power apps,

removed code from the button, and re-added same code, it's not showing any error but during the running app, it throws below error.

the movement when I alter table then I am getting this error. Yes the table has already PrimaryKey mean when I create a table 

always I will use below code 

ID Integer IDENTITY(1,1) PRIMARY KEY,

sqlerroe.PNGsqlerror.PNG

do I need to reconfigure anything from the table or any what is happening when altering table?

 

 

any resolutions to fix this issue.

 

your help would be really appreciated 

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @muralikrishna12 ,

Regarding the formula screenshot that you provided, I could not find any syntax error with it. I think this issue may be related to your SQL Table connection.

 

Please consider remove the SQL Table connection from your canvas app, then re-add it again in your canvas app, then within your Patch formula, re-reference the SQL Table data source, then try your Patch formula again, check if the issue is solved.

Note: When you made some changes to your SQL Table, the previous created SQL Table connection in your canvas app would be invalid. So you need to re-create a new connection to your SQL Table to make the changes take effect in your canvas app.

 

If the issue still exists, please consider re-type the Patch formula within your "Submit" button, then check if the issue is solved.

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
v-xida-msft
Community Support
Community Support

Hi @muralikrishna12 ,

Regarding the formula screenshot that you provided, I could not find any syntax error with it. I think this issue may be related to your SQL Table connection.

 

Please consider remove the SQL Table connection from your canvas app, then re-add it again in your canvas app, then within your Patch formula, re-reference the SQL Table data source, then try your Patch formula again, check if the issue is solved.

Note: When you made some changes to your SQL Table, the previous created SQL Table connection in your canvas app would be invalid. So you need to re-create a new connection to your SQL Table to make the changes take effect in your canvas app.

 

If the issue still exists, please consider re-type the Patch formula within your "Submit" button, then check if the issue is solved.

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-xida-msft 

Thanks for your assistance, that`s right but also one more solution, which i did is close the app, and reopen then its fine. 

TickboxPhil
Advocate IV
Advocate IV

Wow, just had same error and problem after a SQL backend change and hitting Refresh in Power Apps (which should of course pick anything up, or at least warn if the whole Connection is now outdated).

 

Great idea @muralikrishna12 - using the full "Close" on the app and restarting does clear it all without having to fiddle around replacing formula. Phew!

TJpaterson
Regular Visitor

@muralikrishna12 I had the same issue posted and I just removed the data source and re added it. It worked like a charm. 

 

Thank you

joybaylon_
Helper I
Helper I

joybaylon__0-1623207482102.png

Hi I'm also having this kind of error on my end user. But when I opened it on my device, it seems fine. Please help me to resolve the issue.

 

Yep same issue here with a Power App in a solution deployed to our managed environment .  I think in our case is we have added and amended columns in our backend SharePoint list to match the list in our development site; rather than copying a blank list from dev to prod. Luckily we haven't gone live yet so there is time to fix.

One of those quick decisions that you regret tenfold afterwards....😣

 

Specified record not found cens.png

Anyone found a fix for this?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,560)