cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

The operation is invalid. Server Response: A value must be provided for item. clientRequestid:

Using Patch (in PowerApps) to update a table. The request keeps coming back with the message and a series of letters and numbers.

I have checked every field being updated for context. Most are using variables set during the input or selection of data. the Patch statement looks like this in the OnSelect on the Submit button:

 

Patch(
'[dbo].[TSheet]',
Defaults('[dbo].[TSheet]'),
{
EmployeeId_1: Value(Enterid.Text),
tdate: (DataCardValue5),
Tjobno: (DataCardValue3),
tstart: (_startdate),
Tlocs: (_startlat),
Tlocslong: (_startlong),
ps1: (_sw1),
ps2: (_sw2),
ps3: (_sw3),
ps4: (_sw4),
ps5: (_sw5),
ps6: (_sw6),
ps7: (_sw7),
ps8: (_sw8),
ps9: (_sw9),
ps10: (_sw10),
ps11: (_sw11)
}
)

The table has an internal primary key which is meant to increment by 1 with each update.

This is not the only table I get this issue with.

All help is gratefully received.

2 REPLIES 2
Community Support
Community Support

Hi @PaulB1,

Could you please share a bit more about the error message within your app?

I have made a test on my side, and don't have the issue that you mentioned. Please check if you have listed all required/mandatory fields of your SQL table within your Patch function.

Please also check if you have typed proper value for the fields that you listed within your Patch function.

In addition, you could consider take a try to save your data into your data source using Collect function, then check if the issue is solved. The related formula as below:

Collect(DataSource, Item, ...)

More details about Collect function, please check the following article:

Collect function

Please also consider take a try to turn off/disable the "Explicit column selection" option and "Improved app rendering (final validation)" option within the Advanced settings of App settings, then check if the issue still exists.

If the issue still exists, please consider take a try to re-create your app, then check if the issue is solved.

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I resolved the issue by going through each data item and putting a ".Text" of other item on each. Then I was able to refer to the table and not a collection

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (7,631)