cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
duffysp
Advocate I
Advocate I

This app isn't opening correctly

Hi,

 

I'm looking for assistance with a strange problem I'm having with a single android tablet.

I currently have multiple powerapps that are deployed to around 200 devices. I have 1 tablet that is coming up with "This app isn't opening correctly" and have no idea why.

 

I've tried uninstalling the powerapp application from the play store and also clearing the data/cache from the android settings page.

Both of these actions cause any single published app to launch successfully...but only once. When this app is closed, any subsequent apps that are launched (even if its the same app that just launched successfully or a completely different one) will report the error above; It's almost as if powerapps is caching some data which is then correupting the environement which prevents any other apps from launching. This seems to be confirmed by the fact that the data cache on the device being cleared will allow you another single launch before the error happens again.

Several user accounts have been tried on this tablet, the issue persists. The user account it was happening on has been tested on a different tablet and everything is fine. Both tablets having matching Powerapps Versions, the same version of the published apps and the same version of android patches.

 

 

Normally I would just republish the app (as it says "the owner may need to republish the app") but it is happening on ALL apps on this device which suggests an issue with the Powerapps environment instead of a paricular app.

Other than remove the Powerapp application from the playstore and put it back i am very limited in terms of what debugging i can do.

 

The Session ID is: deed3bd2-026a-4796-a0c8-2b9db564cf7

 

Any help appreciated.

14 REPLIES 14

Hi @Maxwell,

 

Is there an ETA on the fix for this? I've tried the Web System View but it is not optimised for these tablets and cannot be enabled.

Is it an update either on the Powerapps or Anrdoid side that seems to be causing this issue? This has affected a portion of the tablets we have here so if there is something we can temporarily suspend updates on to avoid it 'spreading' ir would be prefferable until a fix is released.

 

Thanks.

 

Upgrade Android Sytem Webview version 65.0.3325.109 works for me, PowerApps version 3.18041.2

 

You need to disable Chrome and then go to PlayStore and update the Android System Webview

p13tro
Frequent Visitor

I had this issue yesterday with some of my users using Android Tablets.

 

Solved it (after trying many other things) by getting them to uninstall PowerApps and then reinstalling Power Apps from Google Play store. Simple really, and wish I had told them to do this straight away.

Anonymous
Not applicable

Horray and errrr....

 

The new update ver 3.18042.25 actually fixes this problem

BUT here comes a NEW error (see here)

 

Microsoft will forever keep us busy !!


@EdgarMX wrote:

Upgrade Android Sytem Webview version 65.0.3325.109 works for me, PowerApps version 3.18041.2

 

You need to disable Chrome and then go to PlayStore and update the Android System Webview


 

 

This solved the issue for me too! Thanks!

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (5,526)