cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
davidstone
Kudo Kingpin
Kudo Kingpin

Toggle text disappears on focus

Hi,

 

Something we've just noticed today is that on toggles, the true or false text is not visible when that toggle has focus.

 

Seems to be related to the border thickness - if we set the focused border thickness to 0 the problem doesn't occur.

 

We have to stick within accessibility guidelines, so we can't keep that as a workaround.

 

I've got this issue on my tenant, and have just shared a screen with a user in another tenant and they are experiencing the same.

 

Thanks.

17 REPLIES 17
Anonymous
Not applicable

Hi @davidstone I'm sorry you were experiencing this issue. Are you and other users still seeing this issue with toggles?

 

@Anonymous

Hi,

 

Thanks for coming back to me. Yes, we still have the issue. I've just edited and published again in case any builds had changed it, but it's still the same.

 

Thanks.

Anonymous
Not applicable

adding in @FilipK to review. 

 

@Anonymous

I tried to reroduce, but I do see the strings.  Some questions?
1. Is the control wide enough for you to see the string?

2. Do you have any formulas or conditional formatting on the toggle?

2. If you create a new app with a toggle does it still happnen?

- not filipk@microsoft.com, please private message me if you can't share with everyone

1. We've tested by making the control as big as possible, and the text as small as possible, the result in any case is that while the control has focus, the text is not visible.

2. and 2. - brand new app created from scratch, same result as above.

 

No difference between improved or original rendering.

 

The only way I can retain visibility of the text after toggling is by setting the focused border thickness to zero.

@davidstone Are you able to attach a screenshot? That might help diagnose the problem quicker.

 

Other things worth trying is to use a different browser or try different methods of focusing (keyboard, mouse, or screen reader). 

I can do better than a screenshot!

 

https://youtu.be/qpcU1JV7pOY

 

One thing I didn't realise till making that video is that it only happens when clicking the toggle graphic; not if you just hit the text beside it.

This is a strange problem. I did the exact steps shown in the video (except I started a new app by going to create.powerapps.com directly and selected a new blank tablet app.) I used Chrome version 72.0.3626.119 because that's what the video uses. It works fine for me, whether clicking on the graphic or text.

 

Try upgrading to latest Chrome and Windows updates. Or check if this issue happens on other browsers or when viewing the app from web.powerapps.com.

You're right - it works fine in Internet Explorer. Chrome now updated to Version 72.0.3626.121 (Official Build) (64-bit) - but still the same issue in just Chrome.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (1,733)