cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
seadude
Memorable Member
Memorable Member

Unable to Click Icon in Form DataCard

Hello,

Is anyone else experiencing this? I'm sure it worked last week.

Scenario:

  • Icon (Camera) inside a Form DataCard
    • image.png
  • Form is on the top of the screen
    • image.png
  • No matter what I do in Play Mode, I cannot click the Camera Icon.
    • But I can click the Edit Icon (Pencil) which is OUTSIDE the Form, just fine!
    • image.png

I have like 1 hour to knock this enhancement out and little thing like this blocking the way. Any ideas?

Tried so far:

  • Cutting from Form DataCard and Pasting it back in
  • Adding a new Icon
    • image.png
8 REPLIES 8
v-monli-msft
Community Support
Community Support

Hi @seadude ,

 

I just tested and I cannot reproduce your issue. Please make sure that the DisplayMode of this icon is set to:

DisplayMode.Edit

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the reply @v-monli-msft ,

The displaymode is definitely set to edit. I'll PM you a link to a video showing the issue.

Steps to reproduce:

- Take a working icon (clickable)

- Copy it inside a Form Data Card

- Try clicking

- No go

- Only seems to be happening in this one app.

Things tried so far:

- Check DisplayMode, ensure set to Edit

- Check known-good icon, copy

- Add new icon, apply same code

Please advise.

Thank you

Hi @v-monli-msft ,
I'm unable to upload either a .mp4 or .gif to the forum or a PM (type and size restrictions). Are there any settings that may affect this (experimental, etc.)?
Thanks

Anonymous
Not applicable

Hi @seadude are you still experiencing this issue?

 

@Anonymous 

Yes. This is still an issue. Users are quite upset. There are MANY things happening in the same app that are unexplainable.

  1. Unable to click icon inside Form Data Card
  2. Unable to click icons inside Gallery records
  3. Char(13) not being respected in Labels
  4. Users in South Africa have different behaviour than users in US West2 when using Mobile devices. Differences between Apple Hardware and Samsung

I am experiencing this issue too. NO icons within datacards are clickable!
David_Mullenix
Regular Visitor

Ok, had this issue too but fixed it by making sure the form card was ALSO set to "Displaymode: Edit". 

 

Hope this helps

loicr
Regular Visitor

Same issue here.

The best workaround I found is to open the form in an Edit Mode but with a variable "View".

And to change the DisplayMode of all the datacardvalue to the the variable. So the datacards have a DisplayMode on Edit and icons would work.

Loic

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,982)