cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
terry_schmidt
Level: Powered On

Unable to add some users to model-driven PowerApp

PowerApps Team,

 

I've created a new "production" environment, hooked to the Canada region, with a new database.  I built up a basic model-driven PowerApp in this environment and now I want to add users to the system for demo/trial.  When I go to the PowerApp admin center and add users to the environment, I am only able to successfully add a couple of users, the rest never appear in the list of users.  I have compared the users that worked against the ones that didn't and I can't determine why they aren't working.  Both sets of users have a PowerApps Plan 2 Trial (and Dynamics Customer Engagement Plan Enterprise or CRM Online licenses).  See attachment for screenshots of their licenses.

 

Under the Dynamics Admin Center, there is no security group assigned to the instance - which should leave it open for any user with a license as I understand it.  In fact, although it sees our Azure AD security groups, when I try to assign one, it says it cannot find the security group with that name (another issue) - so I've left it blank.

 

Any ideas on why some users can be added and others cannot?

1 ACCEPTED SOLUTION

Accepted Solutions
terry_schmidt
Level: Powered On

Re: Unable to add some users to model-driven PowerApp

Just as a follow-up to wrap up this message thread:

 

The problem has resolved itself, I believe based on a recent update in August that fixed/added support for cross-regional environments.  I ended up having to re-create the environment, but was able to create it properly in the region our Azure AD existed in (which it wasn't letting me create before).  The users and roles properly pull across now and security is working as expected.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Unable to add some users to model-driven PowerApp

Are those users under the same tenant (the same Office 365 organization)?

 

I will take some further testing on this and will share you the results.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
terry_schmidt
Level: Powered On

Re: Unable to add some users to model-driven PowerApp

Yes, they definitely are.  Thanks, I look forward to any results you have.

terry_schmidt
Level: Powered On

Re: Unable to add some users to model-driven PowerApp

Any follow-up on this by chance? 

 

Much appreciated,

 

Terry

terry_schmidt
Level: Powered On

Re: Unable to add some users to model-driven PowerApp

Just as a follow-up to wrap up this message thread:

 

The problem has resolved itself, I believe based on a recent update in August that fixed/added support for cross-regional environments.  I ended up having to re-create the environment, but was able to create it properly in the region our Azure AD existed in (which it wasn't letting me create before).  The users and roles properly pull across now and security is working as expected.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,800)