cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anandr
New Member

Unable to create New App using Powerapp Studio for Web

 

I receive the error below when I try to create a new app using Powerapp Studio for Web. Please advise. Thanks.

 

 

WebAuthoring abnormal termination.
Client date/time: 2016-12-22T18:55:15.274Z

Version: 2.0.570
Session ID: a3826b6a-915a-92ec-da42-c7ca0d6b150c
errorMessage: Uncaught Error: Core.ApplicationError: [InvalidAuthenticationResult] AuthenticationResult is not valid. Error: Failed to parse the WebAuthenticationResponse.

11 REPLIES 11
v-yamao-msft
Community Support
Community Support

Hi Anandr,

 

To reproduce this issue, could you provide information about:
1. Which browser are you using?
2. What’s the data source your app based on?
3. Do you have any special settings on your Internet?

 

Please try the following ways:
1. Clear the cache and login again
2. Login in InPrivate mode

 

I have tried to create an app from PowerApps studio for Web on IE, Edge, Chrome, using the connection to Common Data Service, SharePoint, the apps can be created properly with no error.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello,

I am still having trouble creating a new app using the PowerApps web studio.

I am able to establish create new connections, create entities and import data into the entity. However I receive the following error when I try to create a new App.

WebAuthoring abnormal termination.
Client date/time: 2016-12-28T14:50:26.837Z
Version: 2.0.572
Session ID: 71b8c432-d77e-bdf6-fb19-9b45974dd481
errorMessage: Uncaught Error: Core.ApplicationError: [InvalidAuthenticationResult] AuthenticationResult is not valid. Error: Failed to parse the WebAuthenticationResponse.

 

My IE version is 11 and the Chrome version is 55. The data source is an Excel worksheet on OneDrive.

 

As suggested I cleared the cache and ran the browser inPrivate mode but still received the same message.

 

I am not sure if the problem is related to OAuth verification. Appreciate any additional suggestions.

 

Thanks.

Anand Ramanathan

Hi Anandr,

 

Thanks for your reply.

 

I tried again to create an app on PowerApps studio for Web on IE, I got the same error message with you occasionally. Sometimes an error message would be shown looks like below, but sometimes I can create an app from Web with no error.
When the error message was shown, I clicked the button to start a new session, but it didn’t work.

Auth error1.PNG

 

After getting this error message, I signed in PowerApps in InPrivate mode, it worked well for me, no error message and I can create an app based on Excel file on OneDrive successfully.

 

I also tried Edge. On Edge, I didn’t get any error message. Do you have Edge to try to create an app from Web?

 

About the error message “Error: Failed to parse the WebAuthenticationResponse”, I will report from my side and involve others to take a further investigation on it. Thanks for your feedback.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Anandr,

 

It seems that this issue has been updated and fixed. Are you now able to create apps using PowerApps studio for Web? Could you try again with it?

 

If you are still experiencing this issue, please help to collect the information for further investigation:
1. What WebAuth endpoint were you using when you saw the error again?
2. Could you capture a Fiddler trace and send it to my email address at v-yamao@microsoft.com?

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi, i have a slightly different issue, but failure is the same, and screen looks the same:

 

WebAuthoring abnormal termination.
Client date/time: 2017-02-01T19:33:59.471Z
Version: 2.0.574
Session ID: 6f9d6058-b808-96a2-6576-4833e51ebb4f
errorMessage: Uncaught Error: Core.ApplicationError: [InvalidAuthorizationCode] Authorization code is not valid. Error: {"Message":"Invalid authorization code. Multi-factor authentication is required."}

anandr
New Member

I had opened a ticket with Microsoft for them to investigate. They responded saying the will be remediating the problem in 6 weeks. They asked me to try this after that time to see if the problem is remediated.

Hi anandr,

 

did you get any indication of the root cause? Is there any change on the end date for the fix? 3 more weeks?

 

I get the same issue for creation using all three supported browser IE11/Edge/Chrome, but I can create the app in PowerApps Studio as a Win10 Store app. Only issue is that this app we're working is a collaboration and not all users have 10. I still can't edit the saved Studio app back in the web portal. I'm using a trial of the Common Data Service for ours

 

Cheers

 

Dan

I am having a similar problem. I get the following error in IE 11. when I use Edge, the Studio For Web  never loads. It works fine in Chrome

 

WebAuthoring abnormal termination.
Client date/time: 2017-03-28T14:39:25.969Z
Version: 2.0.602
Session ID: 499a8fbf-f3aa-fbee-e319-38bda988678c
description: {"error":{"detail":{"exception":{}},"colno":0,"filename":"https://paaeuscdn.azureedge.net/v2.0.602.0/studio/openSource/modified/winjs/js/base.js?v=39de0f2edf1... error","initErrorEvent":"[function]","bubbles":false,"cancelBubble":false,"cancelable":false,"currentTarget":"[window]","defaultPrevented":true,"eventPhase":2,"isTrusted":true,"srcElement":"[window]","target":"[window]","timeStamp":1490711965955,"type":"error","initEvent":"[function]","preventDefault":"[function]","stopImmediatePropagation":"[function]","stopPropagation":"[function]","AT_TARGET":2,"BUBBLING_PHASE":3,"CAPTURING_PHASE":1},"errorLine":0,"errorCharacter":0,"errorUrl":"https://paaeuscdn.azureedge.net/v2.0.602.0/studio/openSource/modified/winjs/js/base.js?v=39de0f2edf1... error","setPromise":"[function]","exception":{}}
stack: null
errorNumber: 0
errorMessage: Script error

 

 

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert

I am getting the same error.(WebAuthoring abnormal termination.
Client date/time: 2017-03-29T21:00:37.820Z...) I need to be able to use IE because I am developing from SharePoint...so I can't use Chrome. If you don't go through the PowerApps launch in SharePoint, the apps associated with the list don't show up in your list view. So frustrating. No fix for this??

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,385)