cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
nagaraj007
Helper V
Helper V

Unable to fetch the data using Lookup function

Hello All,

 

I am new to Powerapps, i have 2 datasources namely 

1. ScanData1 :  URN, InoutDate, User

2. Preregister : URN, CompanyName, Visitor Name

 

Both of them have URN as the common field.

 

I want to get the data from Preregister Database : CompanyName and VisitorName 

 

Please advice how to go about this

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Use this:

ForAll(GalleryName.AllItems, Patch('[dbo].[ScanData1]', Defaults('[dbo].[ScanData1]'),{URN: urn.Text, InOutDate: Now(), User: User().FullName, 'Visitor Name': visitornamelookup.Text, 'Company Name': companylookup.Text}); Select(BarcodeScanner1)

 

If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution

 

 

View solution in original post

17 REPLIES 17
eka24
Super User
Super User

Try this:


LookUp('[dbo].[PreRegister]',urn=ThisItem.URN,CompanyName)
 
 
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution

Hi,

 

I am getting error as Invalid Argument Type near equal sign

Two questions:

1. Is urn in the Table Preregister?
2. Is urn a number field? If so put: Value(ThisItem.URN)

Hi,

I was able to fix the issue. But however i am unable to save to the destination. Please find the attached error message.

Remove the Space in the "Company Name": CompanyName

I get the error as 

 

the specified column CompanyName doesn't exist.

 

My SQL Column has Company Name. 

Please find the attached screenshot

Put the Company Name in single quotes 'Company Name'

I was able to save the data. But however the lookup works fine in the Powerapps, but when it goes to SQL it showing wrong numbers.

 

For ex: attached URN one is abc company and visitor name is nagaraj

and other is def company and visitor name is jagadeesh

 

But SQL shows both as nagaraj and abc company only.

 

Please advice. Attached is the SQL data

And also when ever i scan and save it getting added into the main table also which is not required. Please find the attached screenshot of sql

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,192)