cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Unable to load a Sharepoint list

I have a mobile app where I was getting data from a SharePoint list. One day my app stopped working and I got the error message about too many lookup columns. Despite they were just 12, I have deleted 2 of them and now they are 10. I have refreshed connection, application etc etc, but still getting the same error.

Also I have tried to build another app and connect to the same list - but I am getting the same error.

When checking the data (in "items" of the gallery) I get the message "we didn't find any data"

marpio_0-1603980168896.png

and on the monitor I get this error:

"status": 400,
"message": "The query cannot be completed because the number of lookup columns it contains exceeds the lookup column threshold enforced by the administrator.\r\nclientRequestId:
 
The list has only 10 lookup columns (or person fields)...
I have a copy of the list on another site, and I can connect to that one without problems.
The Sharepoint list works perfectly under sharepoint (forms, workflows, flows etc).
 
Any idea?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Frequent Visitor

After 3 days PowerApps "realized" that something was changed in Sharepoint. So lesson learnt: it may take up to several days before you have a reliable communication/integration between the PA and SP. So far you can just wonderwhy it this happening...

View solution in original post

3 REPLIES 3
Super User III
Super User III

Hi @marpio ,

Have you tried removing the list from the data sources in Power Apps, saving and closing, then adding it back in?

I have already tried to open this list with a brand new PA application, and I have the same result... the problem is in the way PA approaches this list, or the list itself. But, as I've already said, the list in Sharepoint works perfectly (and it is in a production environment, so I cannot play so much with it)

Frequent Visitor

After 3 days PowerApps "realized" that something was changed in Sharepoint. So lesson learnt: it may take up to several days before you have a reliable communication/integration between the PA and SP. So far you can just wonderwhy it this happening...

View solution in original post

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (69,283)