cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vranjan22
Helper III
Helper III

Unpredictable behaviour of Powerapp in designing mode, especially with dropdown controls

Hi,

 

I have been developing apps on PowerApps platform for over a year and there are some basic but very important issues which I have been facing for quite sometime. 

 

At times, there is an unexplainable lag in the system, especially while configuring & using dropdown controls. For example, let us say I am using a table listDesignation in the dropdown. Following is the sample table:

 

Data Source: MS SQL Enterprise Edition

Connectivity: On-premise Data gateway

Table Name: dbo.listDesignation

 

DesignationGrade
ExecutiveE1
Sr. ExecutiveE2
SMEE3
Team LeaderA1
Asst. ManagerA3
Deputy ManagerM1
ManagerM3

 

I am creating dropdown selection  for designation using dropdown control. Under Items of the dropdown control, I am put following:

 

[dbo.listdesignation].Designation

 

Following are my observations:

  1. Either it will show grade info
  2. Either it will display 2-3 records of designation
  3. If I have created a dependent dropdown selection, then the list will be jumbled up (not in order) or does not show value or show incomplete values.
  4. If I have set the Default property of the dropdown as Parent.Default, at times it displays the already stored value, at times it doesn't, irrespective of the fact that the value stored in the field is available in the dropdown.  For example, if the value in the field is Manager, and the dropdown will show the first value (Executive) instead of Manager, when I will select the record.

Most of the times it works beautifully, but at times it creates lot of questions on the credibility of the product. And in online forms, dropdown plays very important part.

 

When I started working on PowerApp, I used to give feedback ratings to the product as 8 or 9, now I will not rate the product more than 3 and I will not be recommending it to any of my clients. 

 

The frequency of such issues has increased in past few months and last few days it has been unbearable. It has resulted in unnecessary delay in the project and I am loosing time and money.

 

I had earlier posted similar issues, but did not get any solution.

 

Any help in this regard would be highly appreciated.

 

Thanks,

Vivek

 

1 REPLY 1
RandyHayes
Super User III
Super User III

@vranjan22 

My first thoughts go toward the on-premise gateway.  When I use that, there are times I notice a lag in the data actually completly loading, and thus I get unusual results for a moment or two until it completes.

Have you notices issues when using other DataSources besides OnPremise?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (61,886)