cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Unstable work of PowerApps with SharePoint online lists. SharePointListTableDataController

The previously created application today began to have issues with reading from and writing data to Sharepoint online lists:

PrtSc1.JPG

PrtSc2.JPG

PrtSc3.JPG

PrtSc4.JPG

PrtSc5.JPG

After several link updates, some errors disappear and others appear

 

-Oleks

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Michael.

 

Yes, it seems that the issue has resolved.

View solution in original post

9 REPLIES 9
Community Support
Community Support

Hi @Oleks,

 

Thanks for the feedback.

Are there any changes have been made under the SharePoint Online lists?

Per my testing, PowerApps has no issues when working with the SharePoint Online list (Custom List).

Also it would be helpful if you could share something about the ShareQPoint list fields type, and the related configurations.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Michael

 

There are not any changes have been made under SharePoint lists. The lists have Number, Single line of text and Lookup columns. All these lists are related with each other by lookup fields with enforcing relationship behavior.

Advocate I
Advocate I

Frequent Visitor

Hi 

 

FYI our app was built 1 month ago with 4 SharePoint lists which fields did not change for the last 15 days.

During last 15 days, we performed about 200 user tests and everything went well until last saturday when these messages appeared.

Data has never been corrupted and has always been accessible, app works well except that these messages appear now continuously.

The only thing we tested last saturdday is changing back and forth the List Option from "Read all items" to "Read items that were created by the user" but after complete rebuilding of the list, messages are still displaying

 

https://powerusers.microsoft.com/t5/PowerApps-Forum/Error-when-trying-to-create-a-controller-of-type...

Hi @Luis and @Oleks,

 

I got a response tolding that a new deployment has just been finished, could you please take a check to see if issue has resolved?

 

Thanks,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Michael.

 

Yes, it seems that the issue has resolved.

View solution in original post

Helper I
Helper I

I am starting to see the same error across all of our apps that are connected to SharePoint lists. The affected apps have been working for the past 4 weeks. What can be changed on my end to rectify?

I'm getting the same errors - starting today when it was working fine yesterday. Made a new thread here: https://powerusers.microsoft.com/t5/PowerApps-Forum/Server-Error-accessing-SharePoint-list/m-p/54262...

 

Must be something on MS backend.

Seems the error is occuring again. Are you able to repeat the fix?

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (39,663)