cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Navig8tr
New Member

UpdateContext problem

I'm a PowerApps rookie and I've searched through previous replies to this but can't seem to find anything that fixes my problem. I have a gallery in screen one with an edit button with onSelect set to

 

UpdateContext({TEST: true})

 

 In another Label inside the gallery and a Label outside of the Gallery I have Text set to

 

TEST

 

I'm just trying to test to make sure the edit button is working. When I try it out I can never get a change.  What am I missing?

Navig8tr_1-1613943577028.png

 


Thank you in advance.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Well I finally found the problem. Somehow I changed the DisplayMode of the gallery to view instead of edit. Once I changed it, it worked like a champ.

View solution in original post

5 REPLIES 5
HenryARPhillips
Continued Contributor
Continued Contributor

Hi,

Before clicking the edit button within Gallery using your same above formula:

HenryARPhillips_0-1613946596300.png

 

After clicking edit:

HenryARPhillips_1-1613946618218.png

 

So not sure what is going on in your app as what you had stated above seems to be doing what you would want to.

 

Also just remember and also worth trying as a troubleshooting step that if you need to use outside the context of your screen, you can use Global variables. So Set(gblTEST,true) as an example.

 

HenryARPhillips_2-1613946700507.png

 

HenryARPhillips_3-1613946719241.png

 

 

Might also be worth checking which property you are typing TEST into of the control.

Appreciate the information. Unfortunately I have tried Set() as well and getting the same results. I'll keep digging. Thank you.

A little more information. I tried creating a new screen/gallery/button etc.. and I got it to work. The only difference was a used a different data source for the gallery. Both are SharePoint lists and as far as I can tell I have the same permissions for both.

Well I finally found the problem. Somehow I changed the DisplayMode of the gallery to view instead of edit. Once I changed it, it worked like a champ.

View solution in original post

HenryARPhillips
Continued Contributor
Continued Contributor

Good spot and I suppose it makes sense as when in View, nothing is active and will not update. Unfortunately must have been that because the button was set to view and not disabled it was still selectable and gave the illusion that it was/should still be doing something.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (71,368)