cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

User name display shows i:0#.f|membership ...

I have a SharePoint list with a person field that shows some user names not correctly. When I use ThisItem.MyColumnName.DisplayName I get 

 

i:0#.f|membership|firstname.lastname@domain

 

but only for some people. Others are fine ( see screenshot). When I use ThisItem.MyColumnName.Email, the entries for these people are blank. 

 

We synchronize our on-premise AD with 365. I am a 365 admin and in the admin center I cannot see why some users would show correctly and others don't. All people in the screenshot have had a 365 license and been working with SharePoint online for almost a year, albeit in a different site collection.  

 

Any ideas what causes this wrong user name display and what to do to correct it?

 

2017-04-03_15-06-38.png

15 REPLIES 15
Highlighted
Community Support
Community Support

Re: User name display shows i:0#.f|membership ...

Hi IngeborgNZ,

 

If you are using a From control, on the Form customization pane, please select the People field and change the Value1 to DisplayName to see if it works.


Per my test, when the Value1 is set as Claims, the value shown on the app would be looks like what you have provided.

1.png

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: User name display shows i:0#.f|membership ...

Hi,

 

it is not a form field. I inserted a vertical gallery and changed the formula to "Operator.DisplayName". Operator is the column name in SharePoint.

 

The screenshot shows the column as it is rendered in a table in Powerapps. Note that this is all the SAME column with different records. The name is showing fine for SOME people, but for others it is with the "i:0#.f|membership". The red arrows point to records with the correct name. The other rows show the problem entries.

 

2017-04-04_17-49-59.png

 

I have spent hours today looking through the properties of these users in Office 365 with Powershell. None of the user Get-MsolUser properties show anything like the "i:0#.f|membership". 

 

Some research points to the timer job that syncs with the user profile service. But that can't be it. Some of the users were syncronised today and their names are still not right. 

 

In SharePoint online, the same list view shows correct. The user properties in the User Profiles is correct.

 

I created another app from the SharePoint list. It also shows the wrong names for the same users in PowerApps.

 

What is PowerApps showing, then? Where does PowerApps take these values from? 

Highlighted
Community Support
Community Support

Re: User name display shows i:0#.f|membership ...

Hi IngeborgNZ,

 

Thanks for your detailed information.

 

Please try to create a connection to Office 365 Users, then use functions to get the display name of the users whose name are not correctly to see if it works properly.

Could you please test this on your side?

 

About Office 365 Users, please check this link for a reference:
https://powerapps.microsoft.com/en-us/tutorials/connection-office365-users/

 

And please provide your Session ID for a further investigation. You could get it under: File>Account>Diagnostics>Session Details.

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: User name display shows i:0#.f|membership ...

Thanks for the suggestion. I did not try it, because the problem no longer presents.

 

Without making any changes to the app, now all names show correctly in the list view.

 

However, I can no longer edit the app in the Windows studio application. It shows yellow triangles with the very unhelpful message that "an unknown error occurred".  I can edit the app fine in the browser, that is, untill the browser decides to thrown an unspecified error and then suggests to restart the application.

 

I have created an app from SharePoint and can edit it in the browser, but when I open it on the phone, I can't see any data.

 

to be honest, this whole PowerApp experience is very unstable and unreliable. Every time I turn around something else is not working.

 

Not an experience that I would entrust with any business process at this point in time.

 

Maddening is also the limitation to the phone if working with SharePoint.

 

When is the SharePoint list forms integration coming????

Highlighted
Community Support
Community Support

Re: User name display shows i:0#.f|membership ...

Hi IngeborgNZ,

 

What’s your current situation?


Are you still getting the issues?

 

When I open the apps based on SharePoint list on the Phone, they all work normally, and I can edit the app and save new records to the data source.

 

Do you have other apps that are notbased on SharePoint list? When you open these apps on your phone device, can you see the data as expected?

 

Please make sure you are always using the latest PowerApps version. If you are still getting the issue, please feel free reply.


Best regards,
Mabel Mao

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: User name display shows i:0#.f|membership ...

Sorry for the late reply. I was offline for two weeks. Returning to my desk I find that the error has re-appeared and some user names are showing as  i:0#.f|membership ...etc. where they were showing fine before.

When I try to edit any app in the browser, using IE11 I get an error

 

2017-05-15_15-17-58.png

 

This is getting more and more frustrating.

 

Please tell me what I need to do to be able to work with PowerApps successfully.

Highlighted
Community Support
Community Support

Re: User name display shows i:0#.f|membership ...

Hi IngeborgNZ,

 

About the user name issue, I will involve someone who is familiar with this issue to take a further investigation. I will back if more information is needed.

 

About the WebAuthoring abnormal termination issue, please try to clear the cache of the browser, and also try to open the browser in InPrivate mode then sign in again to see if it will work for you.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: User name display shows i:0#.f|membership ...

Hi @v-yamao-msft,

 

I followed your suggestion from above and created a connection to the Office365Users. I have a text box where I enter the email address and another text box that uses the command Office365Users.UserProfile(NameInput.Text).DisplayName to show the user name.

 

When I enter the email address of a person that shows with  i:0#.f|membership  in the Sharepoint data source, the display name from Office 365 Users is returned correctly. My session ID is

Session ID: 5b3baaf3-dfc6-83d3-f522-050407d08abd

 

I'd be very keen to get to the bottom of this. I really don't understand why some people show correctly and others don't.

 

2017-05-18_9-35-56.png

 

Session ID: 5b3baaf3-dfc6-83d3-f522-050407d08abd

Highlighted
Community Support
Community Support

Re: User name display shows i:0#.f|membership ...

Hi IngeborgNZ,

 

Thanks for your detailed information.

 

I am trying to involve some who is familiar with this issue to take a further investigation on it. I will back if I get any updates.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (9,196)