cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

UserPhoto and UserPhotoV2 error

Office365Users.UserPhotoV2 failed: The method 'UserPhotoV2' has an invalid value for parameter 'id'

 

Office365Users.UserPhotoV2 failed: The method 'UserPhoto' has an invalid value for parameter 'id'

 

Getting this error everytime during Runtime.

 

I am able to view the profile photos of otherusers but still get this error.

 

My Code:

Office365Users.UserPhotoV2(ThisItem.About_Resource)

 

14 REPLIES 14

Hey @Anonymous 

 

Glad that it worked!! Please let us know if you continue to face any issue. 

 

If this question/ query is resolved, please mark as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi @yashag2255  I am getting this error message.

 

I am using:            Office365Users.UserPhotoV2(varUser.Email)

the image is populating correctly, but still getting error message - Office365Users.UserPhotoV2 failed: The method 'UserPhotoV2' has an invalid value for parameter 'id'.

 

Could you help me with this?

Thanks!

I got the same error as @garrettl said, anyone can help?

llserra
Helper II
Helper II

Hi ,i have same problem with id, really i don't  know how to fix it.

 

In my grid, i have some that are in my office and some not ,for this not people i have a problem with id.

Y tryed for example this:

where:

sin_Imagen-> Its a simple image to display if the item ThisItem.Enviado_por does not exist in my organization

 

If(IsBlank(First(Office365User.SearchUser({searchTerm:ThisItem.Enviado_por})).Mail);
sin_Imagen;
Office365Use.UserPhotoV2(First(Office365User.SearchUser({searchTerm:ThisItem.Enviado_por})).Id);
)

 

It's really strange because i type just only:

 

If(IsBlank(First(Office365User.SearchUser({searchTerm:ThisItem.Enviado_por})).Mail);
sin_Imagen;
sin_Imagen
)

Works and all people with image: sin_imagen

 

If i type:

Office365Use.UserPhoto(First(Office365Use5.SearchUser({searchTerm:ThisItem.Enviado_por})).Id)

 

Works for all people in my office, display his image ,but for people doesn't it display error with id

 

And for:

 

If(IsBlank(First(Office365User.SearchUser({searchTerm:ThisItem.Enviado_por})).Mail);
sin_Imagen;
Office365Use.UserPhotoV2(First(Office365User.SearchUser({searchTerm:ThisItem.Enviado_por})).Id);
)

 

Not image for anyone

 

Any idea?

Thanks for all

 

Perfect

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (3,631)