cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sergibarca
Level: Powered On

Using AzureLogAnalyticsDataCollector.SendData error

I'm trying to send some data tu Log Analytics using Azure Log Analytics Data Collector in preview. The problem is that is throwing the some error every time Error of AzureLogAnalyticsDataCollector.SendData: { "Error": "InvalidDataFormat", "Message": null }.

Anyone know how can send information well?

 

I've try this:

AzureLogAnalyticsDataCollector.SendData("Event";"{'message':'Btn pressed'}")

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Using AzureLogAnalyticsDataCollector.SendData error

Hi @sergibarca ,

 

According to the documentation here:

https://docs.microsoft.com/en-us/connectors/azureloganalyticsdatacollector/#send-data

Below are the required Parameters:

Name Key Required Type Description
JSON Request body
body True string

Send data to Azure Log Analytics workspace.

Custom Log Name
Log-Type True string

Name of the custom log.

 

If this issue remains after you make sure both are included correctly, then this might be a temporary issue since this connector is still in preview. I have found another thread that has the same error:

https://powerusers.microsoft.com/t5/Expressions-and-Formulas/AzureLogAnalyticsDataCollector-not-work...

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: Using AzureLogAnalyticsDataCollector.SendData error

Hi @sergibarca ,

 

According to the documentation here:

https://docs.microsoft.com/en-us/connectors/azureloganalyticsdatacollector/#send-data

Below are the required Parameters:

Name Key Required Type Description
JSON Request body
body True string

Send data to Azure Log Analytics workspace.

Custom Log Name
Log-Type True string

Name of the custom log.

 

If this issue remains after you make sure both are included correctly, then this might be a temporary issue since this connector is still in preview. I have found another thread that has the same error:

https://powerusers.microsoft.com/t5/Expressions-and-Formulas/AzureLogAnalyticsDataCollector-not-work...

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,998)