cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ChrisSullivan
Helper III
Helper III

Using Flow Variables after they are passed back to PowerApp without running flow again.

Hello Power Appers,

 

I Just start using flows in my apps, 

That said I have a few question I have not found an answer to, and or fix for. 

 

I have a Flow that Collects Variables from a PowerApp button. The flow creates a Sharepoint item based on the variables sent from power apps,  and then passes that Items ID back to Power apps. I want to use this Variable to patch some other list but it seems that every time I do so it reruns the Flow and creates more of the original item

 

The code looks as such . 

ChrisSullivan_0-1616186132221.png

 

 

 

 

 

 

 

 

 

 

 

ChrisSullivan_2-1616186221746.png

It seems like every time I use the CopyItemID variable, It creates an new item in the original list. Like it is running the flow every time I use the variable. Is there a way to use this variable without it running the flow again?

 

1 ACCEPTED SOLUTION

Accepted Solutions

I think there is a missing „)“ in your first „if“ statement. Bevor your “;”

View solution in original post

6 REPLIES 6
Mira_Ghaly
Dual Super User II
Dual Super User II

@ChrisSullivan 

I believe you are calling are calling your flow twice , Both 1 and 2 are calls to your flow so you need to remove Number 1 and Keep number 2 as this sets the value you are returning from your flow

Mira_Ghaly_0-1616210974747.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
ChrisSullivan
Helper III
Helper III

Mira,

Thanks for the response! This is exactly what I thought at first. Odd thing is when I remove the first call. I get red X and squiggles. 

Its as if Powerapps has no idea what the Variable is when I only put it in Set().

ChrisSullivan_0-1616418518751.png

ChrisSullivan_1-1616418537796.png

 

Any thoughts?

 

Mira,

Thanks for the response! This is exactly what I thought at first. Odd thing is when I remove the first call. I get red X and squiggles. 

Its as if Powerapps has no idea what the Variable is when I only put it in Set().

ChrisSullivan_0-1616426844651.png

 

ChrisSullivan_1-1616426844652.png

 

 

Any thoughts?

I think there is a missing „)“ in your first „if“ statement. Bevor your “;”

Wow, Thank you max81. Stupid me. 
You stare at these things long enough, your guaranteed to miss Newbie mistakes like this! 👍


max81
Kudo Kingpin
Kudo Kingpin

I did the same mistakes also several times so I’m used to look for missing brackets. 😉

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (4,399)