cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Using all 3 Modes in the same form(new,edit,view)

Hey Guys, 

Im starting a new thread because my last thread was kinda confusing. 😛

 

So here is my detailed explanation: 

 

App Structure:

- Im loading all my CDS data into a local Collection.

- My gallery screen is filled with the local Collection items (but only shows Projekt No, order no and date)

- I got six other screens with forms which has my Local collection as datasource.

-  I have a save Button with a if  condition about connection status

  - connected : patch forms to CDS

  - !connceted: patch forms to offlineDataCollection 

This structure is already working 🙂

 

The Idea I want to implement

- I have a "+" button for a new item. That means my six forms has the mode "new" and all input fields in my forms are empty.

- I have a ">" button to edit a existing item (selected item from gallery). that means he switches to "edit" mode and fill the input fields in my forms with the data of the selected item.

 - For View mode there is a "View" button. I think its the same algorithm as the edit button has.

 

So my Question is what do I need to setup in my app ?

I have tried to use this guide as help. But I cant fill the forms :(.

My Edit mode is alaways like the New mode

MyGalleryMyGallery"Edit Mode" Screen1 - form1"Edit Mode" Screen1 - form1

 

 

7 REPLIES 7
Super User III
Super User III

@PivotMananger 

From what I understand your form's new and edit modes are showing exactly the same result.  I have a couple of suggestions:

 

#1 Make sure your gallery and your form have the same datasource in the Datasource property

 

your_datasource_name

 

#2 Change the Item property of your form to this code

 

Gallery1.Selected

 

#3 Make sure to define what mode the form should open. Change the OnSelect property of your nav buttons to this code.

 

Add:  NewForm(your_form_name);Navigate(other_screen_name,None);
Edit: EditForm(your_form_name);Navigate(other_screen_name,None);

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

 

 

My Form SettingsMy Form Settingsmy Gallery Settingsmy Gallery SettingsMy ButtonMy Button

 

This doesnt work either 😕

it works If I use a new Screen with seperate forms  (even with local collection) 

image.png

 

So I really dont know what went wrong :s

@PivotMananger 

If your issue is solved please close the thread.

only 50% working (does not work with toggles

on start Im saving my 2 options from my option set to 2 local variables

 

    Set(
        OptionValuesJ;
        OptionValues.'153490000'
//True
    );;
    Set(
        OptionValuesN;
        OptionValues.'153490001'
//False
    )

 

 

This is how im setting up my datacard with toggles

image.png

 

Now how do i read the right values from my toggle datacards in view and edit mode ? 

new mode does work 🙂

Ok somehow my local variables arent readable anymore.  

image.png

How can i setup offline option sets for my toggles ? (true or false)

so i can save them into my local collection ?

 

 

push 

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (93,811)