cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Values won't pass to new form

Hello,

 

I have two forms on my PowerApp, New Risk Assessment and New Risk (multiple risks can be added to one risk assessment session). However, I am having difficulty passing the Risk Assessment ID and Title values to the New Risk form. 

 

Here is the code I had been using which worked last week but now whenever I navigate to a new page the Risk Assessment Title field is blank. 

 

titlecodeproblem.PNG

 

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User III
Super User III

@Anonymous 

Try changing your formula to the following:

Navigate('New Risk', Fade, {DataCardValue1: DataCardValue134.Text})

This will create and set a context variable on the 'New Risk' screen with the text value from the DataCardValue134 control.

If you are trying to set another DataCardValue1 control on the 'New Risk' screen, then this process will not work.  Instead, consider setting the Default property of your DataCard to the context variable.  Or better yet, skip the variable and just set the Default property to DataCardValue134.Text

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

5 REPLIES 5
RandyHayes
Super User III
Super User III

@Anonymous 

Try changing your formula to the following:

Navigate('New Risk', Fade, {DataCardValue1: DataCardValue134.Text})

This will create and set a context variable on the 'New Risk' screen with the text value from the DataCardValue134 control.

If you are trying to set another DataCardValue1 control on the 'New Risk' screen, then this process will not work.  Instead, consider setting the Default property of your DataCard to the context variable.  Or better yet, skip the variable and just set the Default property to DataCardValue134.Text

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

Anonymous
Not applicable

you need to add "Text" as DataCardValue134.Text to pass the value.

 

Thanks.

v-xida-msft
Community Support
Community Support

HI @Anonymous ,

Could you please share a bit more about the DataCardValue134 within your formula?

Does the DataCardValue134 store the Risk Assessment Title value?

 

Based on the formula that you provided, I think there is something wrong with it. Please consider modify your formula as below:

Navigate('New Risk', Fade, {DataCardValue1: DataCardValue134.Text})

Note: The DataCardValue134 represents a control rather than a Text value within your app.

 

In addition, as an alternative solution, you could also consider take a try to set the Risk Assessment Title value into a global variable, then you could use this global variable value in your app everywhere.

Modify your formula as below (set the OnSelect property of the "+" icon to following😞

Set(CurrentRiskAssessmentTitle, DataCardValue134.Text);
Navigate('New Risk', Fade)

Please consider take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

The navigate formula still doesn't work but setting the default value did! Thank you so much!

Anonymous
Not applicable

Hi @RandyHayes ,

 

This solution had been working great for me however, I just realized that the passed ID value has not been saving to SharePoint. Any idea on what to do?

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,905)