cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AaronTheYoung
Helper III
Helper III

Variables are not getting SET in App start

My app had been working great for days, but of course I wasn't done with it.  Now, I can't even get some simple variables set.  In the App Start section, I define the following variables and none of them seem to get set.  Even the very simple ones:

 

Set(varUserEmail, User().Email);
Set(varUser, User());
Set(varUserF, User().FullName);
Set(CheckInState,LookUp(Sort('OfficeCheckINOUT-DATA', ID, Descending),Title=varUserF && CheckedInStatus="X").CheckedInStatus);
Set(TEST, "TEST");

 

The formula on my test page to view the simple TEST variable is:

AaronTheYoung_0-1597365284424.png

Yet, all I get is the TEXT portion of my label:

AaronTheYoung_1-1597365364405.png

 

 

Any ideas as to what I've done to create this problem?

4 REPLIES 4
WarrenBelz
Super User
Super User

Hi @AaronTheYoung ,

Firstly try putting the TEST set higher up - I have a feeling that the code below is failing and not running the next Set command

Set(
   CheckInState,
   LookUp(
      Sort(
         'OfficeCheckINOUT-DATA', 
         ID, 
         Descending
      ),
      Title=varUserF &&
      CheckedInStatus="X"
   ).CheckedInStatus
)

If so, try this

With(
   {
      vData:
      Sort(
         'OfficeCheckINOUT-DATA', 
         ID, 
         Descending
      )
   },
   Set(
      CheckInState,
      LookUp(
         vData,
         Title=varUserF &&
         CheckedInStatus="X"
      ).CheckedInStatus
   )
)

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

NONE of the variables are being set. Before or after that code. All of this variable setting was working. This is CRAZY frustrating. I think I'm going to open up a ticket with MS.  This seems broken.

@AaronTheYoung ,

It seems so - you can lodge a Support Ticket with Microsoft here

-Dennis
Advocate II
Advocate II

Experiencing the exact same issue PLUS formulas are not calculating.

NO variables are setting. On any screen. Even when triggered with buttons

Also a loader screen which has a visibility condition of

CountRows(gallery1.AllItems) >10 doesnt work even though the gallery has loaded and has way more than 10 items.

This just started recently. There were no changes to the app. One day it worked, the next it didn't.

 

Please let me know if you find a solution.


Thanks!

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (3,581)