cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bhalchandra
Frequent Visitor

Want to show Group by fields in Power app

Hi All,

I have created a database in SharePoint like below

Volumetric NameVolumeItem Code No.Nominal Volume PortTolerance
Volumetric flask10W 195 244M1221
Volumetric flask10W 195 244M3443
Volumetric flask10W 195 244M5659

 

I want to show group by item based Volumetric Name, Volume & Item Code No. in the power app gallery.

because Volumetric Name, Volume, Item Code all 3 fields are common.

how to show in Power App.

 

Thanks in advance.

 

 

 

18 REPLIES 18
mdevaney
Super User III
Super User III

@bhalchandra 

This code will group together the table if you put it in the Items property of the gallery.

 

GroupBy(
    your_datasource_name
    "Volumetric Name", "Volume", "Item Code No.",
    "GroupedData"
)

 

For more examples like this one please check out my FREE Collections Cookbook.

https://powerusers.microsoft.com/t5/Community-App-Samples/Collections-Cookbook-50-Visual-Examples-am...

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

it shows error , please find attached

Volumetric Item name is Combo Box.

 

 

@bhalchandra 

What column type is Volumetric Item Name is SharePoint (examples: single line text, choices, etc.). 

Its a Choice.

@bhalchandra 

OK, here's a revised solution to handle the Choices column.

 

GroupBy(
    AddColumns(
        your_datasource_name,
        "Volumetric Name Text", 
        'Volumetric Name'.Value
    ),
    "Volumetric Name Text", "Volume" , "Item Code No."
)

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

same error , please find attachment 

My table name is - @CalibrationDB

Fields - Volumetric Item name , Volume , Item Code no

 

 

@bhalchandra 

You missed a comma after [@CalibrationDB],

not resolved

@bhalchandra 

You mistyped this code:  'Volumetric Name'.Value

 

Your screen is showing this instead:  'Volumetric Name".Value

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (47,554)