cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Web Authoring Abnormal Termination

I Keep on getting this error whenever i try to create an app with any template.

 

WebAuthoring abnormal termination.
Client date/time: 2019-06-17T09:41:38.179Z
Version: 3.19061.14 (v3.19061.14.116669235)
Session ID: 3cfae511-2a16-40be-953b-c02ce5f54bf5
description: {"exception":{"isCritical":true,"detail":{"exception":{}}},"error":"[circular]","promise":{"_oncancel":null,"_nextState":null,"_state":{"name":"error","enter":"[function]","cancel":"[function]","done":null,"then":null,"_completed":"[function]","_error":"[function]","_notify":"[function]","_progress":"[function]","_setCompleteValue":"[function]","_setErrorValue":"[function]"},"_listeners":null,"_value":"[circular]","_isException":false,"_errorId":25,"done":"[function]","then":"[function]"},"id":25,"setPromise":"[function]"}
stack: TypeError: Cannot read property 'authoringToken' of null
at r.buildGeneralRequestHeader (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/AppMagic.WebAuthoring.js?v=3.19...)
at e.<anonymous> (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/AppMagic.WebAuthoring.js?v=3.19...)
at https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...
at Object.next (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...)
at a (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...)
at Object.p [as _notify] (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at Object.enter (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at c.Class.derive._oncancel._run (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at c.Class.derive._oncancel._completed (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at Object.p [as _notify] (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
errorNumber: 0
errorMessage: Cannot read property 'authoringToken' of null
callStack: TypeError: Cannot read property 'authoringToken' of null
at r.buildGeneralRequestHeader (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/AppMagic.WebAuthoring.js?v=3.19...)
at e.<anonymous> (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/AppMagic.WebAuthoring.js?v=3.19...)
at https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...
at Object.next (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...)
at a (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/js/Core.js?v=3.19061.14.116669235:...)
at Object.p [as _notify] (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at Object.enter (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at c.Class.derive._oncancel._run (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at c.Class.derive._oncancel._completed (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)
at Object.p [as _notify] (https://cdn-paaprodeus.azureedge.net/v3.19061.14.116669235/studio/openSource/modified/winjs/js/base....)

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

hey @RandyHayes 

 

thank you for taking the time to reply. i don't know what happened, but PowerApps is now working in my laptop. 

 

Regards,

Al

View solution in original post

7 REPLIES 7
Highlighted
Super User III
Super User III

@Anonymous 

Try to do this action in an In-Private Edge session (right click your Edge icon and choose "New InPrivate Window")

navigate to the PowerApps.com site and login again there with your credentials.

I assume this works on other computers, so, does it work with your credentials on other computers as well?

If the InPrivate session works, then there is something gone wrong with your credentials in your browser.  I would consider a full logout in the browser.  Clear cache.  Restart browsers, etc.

 

I hope that is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!
Highlighted
Anonymous
Not applicable

@RandyHayes 

It still doesnt work 😞

 

I tried accessing my account through other people's laptop -- it worked. but for some reason, when i open power apps through my laptop, it displays the same error message.

Highlighted

@Anonymous 

It sounds like the issue then is definitely on your computer.

You might want to go into the Windows Credential Manager and remove entries for your account that would be related to your login.  That would at least be my next step to take.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!
Highlighted
Anonymous
Not applicable

hi @RandyHayes 

 

thank you for your reply -- what do you mean remove the related logins? according to my web credentials, the only login I did with microsoft is the account i am currently using. would it be okay for you to expound what you mean?

 

many tanks,

al

Highlighted

@Anonymous 

Yes, I would first determine how you are connected to your account - is it via login only, or do you have your work/school account connected to your Windows profile.  Also, even before that, is your computer joined to the Azure AD or is it on its own domain/workgroup?  If these don't apply and you are logging in through your browser sessions only, then I would next look to remove the reference to your login in the Credential Manager in Windows on that computer.  Go to the start menu and type Credential Manager.  In there you will see all of the places that Windows is recording and holding credential information.  I would remove the one for your Microsoft login, then attempt to log back in through the browser and see if the problem is resolved.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!
Highlighted
Anonymous
Not applicable

hey @RandyHayes 

 

thank you for taking the time to reply. i don't know what happened, but PowerApps is now working in my laptop. 

 

Regards,

Al

View solution in original post

Highlighted

@Anonymous 

Don't you just love those mysteries!! Smiley Frustrated

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (13,525)