cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
andrewsimmans
Advocate II
Advocate II

When I import a Canvas App then it fails to open I get an SQL error "Requested Operation is Invalid. Server Response: [table name] failed: Bad Data Source"

I have an App that is accessing Azure SQL using SQL Credentials. When I export it as a Package and then Import it, the App works OK when run in a browser (Chrome) and works OK when run in the iPhone App. However when it is run in the Windows Power App (as downloaded from the Microsoft Store) it comes up with the error message as per the screen shot.

 

If I then edit the App and remove all SQL connections and re-add them the error message goes away and the App works.

 

As I am developing an App for offline then it is essential the App works in the Windows Power App. 

4 REPLIES 4
jekakou
Community Support
Community Support

Hello,  

Indeed this is the mitigation for the issue:

Powerapps to Azure SQL Server connection sudden error Bad Data source Inner exception, Not a valid d...

[BUG] "Bad data source - not a valid data source" ... - Power Platform Community (microsoft.com)

 

However I would suggest you to create a support ticket to have more insight about this behavior from PowerPlatform team.

Thanks Jekakou

 

In fact the error I am reporting is NOT the same as the errors you have linked to. I used to have issues like those reported but now things are working OK in the Browser and in the iphone App.

 

What is not working is just the Windows Store Power App which is why I wanted to report this to the PowerApps team.

 

I am confused about your comment to raise a support ticket - I thought this was the forum to report issues to the PowerApps team so they get fixed - do I need to raise a support ticket as well?

 

All I want is to get it fixed!

 

 

@andrewsimmans 

 

Regarding this issue,

 

1) Although you claimed it was not the issue, try this  anyway in case as @jekakou suggested.

disabling the advanced sql connector feature fixes things

 


2) try also anything else in those links from @jekakou 

 

3) Next you should try the following:

   a) make.powerapps.com -> Data -> Connections -> Delete all Connections related to the SQL, then do the step below:

   b) Uninstall the Power Apps Native Mobile Application (not referring to the specific Power App - referring to the whole native Power Apps Mobile App on Windows Phone) completely - then install it again.

See if #3 above resolves it.

 

If #3 above does not work, we would concur with @jekakou and to start the support ticket as was suggested.

 

As for your concern about the community post:

 

Forum is for problem for which solution can benefit the whole community.

 

Support ticket is not the same as a Community Forum post here, and so support ticket may still be needed in case there is an issue for which:

 

1) Microsoft must diagnose the issue by collecting more information from you specifically, and/or to engage an engineer to fix your issue, or,

2) if it is specifically a very niche issue in your specific case only that requires attention,

3) in certain other cases as well

 

Some issues fall under both categories above where it can benefit the community at large, but still may benefit from a support ticket as well so may require both actions.

 

Anybody on forum can feel free to just recommend you start a support ticket, however, notice that if someone with the Employee tag suggests you to do, i.e. Microsoft Employee, it is probably very wise to do so especially in that case.

 

That does not necessarily mean it is not an issue which will also benefit the community, so if you want, you can post updates in this thread as well.

 

If you have more questions about this specific matter about the forum post as opposed to support ticket, we recommend that you should just check with @jekakou in that case.

Hi PowerActivate

 

Thanks for your comments.

 

In terms of fixing the issue I already have a workaround which I put in my original post:

 

"If I then edit the App and remove all SQL connections and re-add them the error message goes away and the App works." 

 

I am happy to stick with this work around - what I wanted to do was make sure that someone in Microsoft knew.

 

Your comments about the community post are very useful - I will raise a support ticket as suggested.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,037)