cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mgodby
Post Patron
Post Patron

Why do attachments not work when app is published but does when in Studio?

I have an attachments object here in powerapps.

gimmeabreakpowerappschrist.png

When I'm in studio I can successfully download the files. But when I publish the app and try to download a file, this happens.

 

ispowerappsajokeathispoint.png

What is going on here? Isn't studio supposed to simulate the app actually being published? Why does it work in studio but not when I publish the app? I remember this working fine a few days ago and I haven't changed anything since then, this just started happening out of nowhere. 

1 ACCEPTED SOLUTION

Accepted Solutions
Mgodby
Post Patron
Post Patron

noticed it was actually failing in studio too where the file was corrupted or empty. fixed it  by changing the "Value" property of the attachment.

 

WHY.png

View solution in original post

1 REPLY 1
Mgodby
Post Patron
Post Patron

noticed it was actually failing in studio too where the file was corrupted or empty. fixed it  by changing the "Value" property of the attachment.

 

WHY.png

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (3,201)